summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-nixio/axTLS/www/lua/test_main.lp
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-nixio/axTLS/www/lua/test_main.lp
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-nixio/axTLS/www/lua/test_main.lp')
-rw-r--r--libs/luci-lib-nixio/axTLS/www/lua/test_main.lp31
1 files changed, 31 insertions, 0 deletions
diff --git a/libs/luci-lib-nixio/axTLS/www/lua/test_main.lp b/libs/luci-lib-nixio/axTLS/www/lua/test_main.lp
new file mode 100644
index 0000000000..917ee1e536
--- /dev/null
+++ b/libs/luci-lib-nixio/axTLS/www/lua/test_main.lp
@@ -0,0 +1,31 @@
+<html>
+<head><title>Embeded Lua Test</title></head>
+
+<body>
+cgi = {
+<?lua
+for i,v in pairs (cgi) do
+ if type(v) == "table" then
+ local vv = "{"
+ for a,b in pairs(v) do
+ vv = string.format ("%s%s = %s<br>\n", vv, a, tostring(b))
+ end
+ v = vv.."}"
+ end
+?>
+<%= i %> = <%= tostring(v) %> <br>
+<%
+end
+%>
+}
+<br>
+Remote address: <%= cgilua.servervariable"REMOTE_ADDR" %>
+<br>
+Is persistent = <%= tostring (SAPI.Info.ispersistent) %>
+<br>
+ap = <?lua= tostring(ap) ?> <br>
+lfcgi = <% = tostring(lfcgi) %> <br>
+<%= (ap and ap.handler()) or "" %> <br>
+
+</body>
+</html>