summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-nixio/axTLS/www/lua/test_fs.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-nixio/axTLS/www/lua/test_fs.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-nixio/axTLS/www/lua/test_fs.lua')
-rw-r--r--libs/luci-lib-nixio/axTLS/www/lua/test_fs.lua23
1 files changed, 23 insertions, 0 deletions
diff --git a/libs/luci-lib-nixio/axTLS/www/lua/test_fs.lua b/libs/luci-lib-nixio/axTLS/www/lua/test_fs.lua
new file mode 100644
index 0000000000..566ed8b204
--- /dev/null
+++ b/libs/luci-lib-nixio/axTLS/www/lua/test_fs.lua
@@ -0,0 +1,23 @@
+function link_dir (dir, base)
+ local path = base.."/"..dir
+ local mode = lfs.attributes (path).mode
+ if mode == "directory" then
+ return string.format ('<a href="%s">%s</a>',
+ cgilua.mkurlpath ("test_fs.lua", { dir = path }),
+ dir)
+ else
+ return dir
+ end
+end
+
+cgilua.htmlheader ()
+cgilua.put ("<h1>Testing Filesystem library</h1>\n")
+cgilua.put ("<table>\n")
+cgilua.put ("<tr><td colspan=2>Testing <b>dir</b></td></tr>\n")
+local i = 0
+local dir = cgi.dir or "."
+for file in lfs.dir (dir) do
+ i = i+1
+ cgilua.put ("<tr><td>"..i.."</td><td>"..link_dir(file, dir).."</td></tr>\n")
+end
+cgilua.put ("</table>\n")