summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-nixio/axTLS/www/lua/test_conc.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-nixio/axTLS/www/lua/test_conc.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-nixio/axTLS/www/lua/test_conc.lua')
-rw-r--r--libs/luci-lib-nixio/axTLS/www/lua/test_conc.lua38
1 files changed, 38 insertions, 0 deletions
diff --git a/libs/luci-lib-nixio/axTLS/www/lua/test_conc.lua b/libs/luci-lib-nixio/axTLS/www/lua/test_conc.lua
new file mode 100644
index 0000000000..bbb9be784a
--- /dev/null
+++ b/libs/luci-lib-nixio/axTLS/www/lua/test_conc.lua
@@ -0,0 +1,38 @@
+cgilua.htmlheader()
+if ap then
+ local pid, ppid = ap.pid ()
+ if not ppid then
+ ppid = "no parent pid"
+ end
+ cgilua.put ("pid = "..pid.." ("..ppid..")".."\n")
+end
+
+assert(type(stable.get) == "function")
+assert(type(stable.set) == "function")
+
+cgilua.put"stable.pairs = {<br>\n"
+for i, v in stable.pairs () do
+ cgilua.put (i.." = "..tostring(v).."<br>\n")
+end
+cgilua.put"}<br>\n"
+
+local counter = stable.get"counter" or 0
+stable.set ("counter", counter + 1)
+
+local f = stable.get"f"
+if not f then
+ local d = os.date()
+ stable.set ("f", function () return d end)
+else
+ cgilua.put ("f() = "..tostring (f ()))
+end
+
+cgilua.put"<br>\n"
+for i = 1,800 do
+ cgilua.put (i)
+ for ii = 1,1000 do
+ cgilua.put ("<!>")
+ end
+ cgilua.put ("\n")
+end
+cgilua.put ("End")