summaryrefslogtreecommitdiffhomepage
path: root/core
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-04-14 13:42:56 +0000
committerSteven Barth <steven@midlink.org>2008-04-14 13:42:56 +0000
commit0476a479cad58059c3dab31266fe2d1530645807 (patch)
treeaab1a672554800154009565fdac399dc937792e5 /core
parent0a1a25d19ad1d800a2cab6eecf8e818cddeefd8c (diff)
* Initial translation for English
Diffstat (limited to 'core')
-rw-r--r--core/Makefile2
-rw-r--r--core/src/ffluci/i18n/cbi.en8
-rw-r--r--core/src/ffluci/i18n/default.en22
-rw-r--r--core/src/ffluci/menu.lua3
-rw-r--r--core/src/ffluci/view/cbi/header.htm2
-rw-r--r--core/src/ffluci/view/cbi/nsection.htm2
-rw-r--r--core/src/ffluci/view/header.htm4
7 files changed, 33 insertions, 10 deletions
diff --git a/core/Makefile b/core/Makefile
index 3fb7f6df8..c6c7ede67 100644
--- a/core/Makefile
+++ b/core/Makefile
@@ -1,7 +1,7 @@
LUAC = luac
LUAC_OPTIONS = -s
-FILES = ffluci/debug.lua ffluci/view/*.htm ffluci/view/cbi/*.htm
+FILES = ffluci/debug.lua ffluci/view/*.htm ffluci/view/cbi/*.htm ffluci/i18n/*
CFILES = ffluci/util.lua ffluci/http.lua ffluci/fs.lua \
ffluci/sys.lua ffluci/model/uci.lua ffluci/model/ipkg.lua \
diff --git a/core/src/ffluci/i18n/cbi.en b/core/src/ffluci/i18n/cbi.en
index 7c159ce50..6069cec45 100644
--- a/core/src/ffluci/i18n/cbi.en
+++ b/core/src/ffluci/i18n/cbi.en
@@ -1,4 +1,4 @@
-uci_add = "Add entry"
-uci_del = "Remove entry"
-uci_save = "Save configuration"
-uci_reset = "Reset form" \ No newline at end of file
+cbi_add = "Add entry"
+cbi_del = "Remove entry"
+cbi_invalid = "Error: Invalid input value"
+cbi_addopt = "-- Field --" \ No newline at end of file
diff --git a/core/src/ffluci/i18n/default.en b/core/src/ffluci/i18n/default.en
new file mode 100644
index 000000000..726095ae7
--- /dev/null
+++ b/core/src/ffluci/i18n/default.en
@@ -0,0 +1,22 @@
+add = "Add"
+save = "Save"
+reset = "Reset"
+
+load = "Load"
+webif = "Webinterface"
+public = "Public"
+admin = "Administration"
+apply = "Apply"
+changes = "Changes"
+revert = "Revert"
+
+index = "Overview"
+system = "System"
+services = "Services"
+network = "Network"
+wifi = "Wifi"
+status = "Status"
+statistic = "Statistic"
+
+config = "Configuration"
+path = "Path" \ No newline at end of file
diff --git a/core/src/ffluci/menu.lua b/core/src/ffluci/menu.lua
index 0a1aad5d1..ff4c547f5 100644
--- a/core/src/ffluci/menu.lua
+++ b/core/src/ffluci/menu.lua
@@ -36,7 +36,8 @@ modelpath = ffluci.config.path .. "/model/menu/"
-- Menu definition extra scope
scope = {
- translate = ffluci.i18n.translate
+ translate = ffluci.i18n.translate,
+ loadtrans = ffluci.i18n.loadc
}
-- Local menu database
diff --git a/core/src/ffluci/view/cbi/header.htm b/core/src/ffluci/view/cbi/header.htm
index 20b4aac7f..1b69a3a31 100644
--- a/core/src/ffluci/view/cbi/header.htm
+++ b/core/src/ffluci/view/cbi/header.htm
@@ -3,5 +3,5 @@
<div>
<script type="text/javascript" src="<%=media%>/cbi.js"></script>
<input type="hidden" name="cbi.submit" value="1" />
- <input type="submit" value="<%:cbi_save Speichern%>" class="hidden" />
+ <input type="submit" value="<%:save Speichern%>" class="hidden" />
</div>
diff --git a/core/src/ffluci/view/cbi/nsection.htm b/core/src/ffluci/view/cbi/nsection.htm
index 9c54a9942..0f7601a94 100644
--- a/core/src/ffluci/view/cbi/nsection.htm
+++ b/core/src/ffluci/view/cbi/nsection.htm
@@ -12,6 +12,6 @@ section = self.section %>
<div class="cbi-section" id="cbi-<%=self.config%>-<%=self.section%>">
<h2><%=self.title%></h2>
<div class="cbi-section-descr"><%=self.description%></div>
- <input type="submit" name="cbi.cns.<%=self.config%>.<%=self.section%>" value="<%:cbi_cns Eintrag anlegen%>" />
+ <input type="submit" name="cbi.cns.<%=self.config%>.<%=self.section%>" value="<%:cbi_add Eintrag anlegen%>" />
</div>
<% end %>
diff --git a/core/src/ffluci/view/header.htm b/core/src/ffluci/view/header.htm
index 40d54f516..1bfc7a02d 100644
--- a/core/src/ffluci/view/header.htm
+++ b/core/src/ffluci/view/header.htm
@@ -65,11 +65,11 @@ require("ffluci.http").htmlheader()
<div><%:config Konfiguration%>
<ul>
<% if ucic then %>
- <li><a href="<%=controller%>/admin/uci/changes"><%:changes Änderungen:%> <%=ucic%></a></li>
+ <li><a href="<%=controller%>/admin/uci/changes"><%:changes Änderungen%>: <%=ucic%></a></li>
<li><a href="<%=controller%>/admin/uci/apply"><%:apply Anwenden%></a></li>
<li><a href="<%=controller%>/admin/uci/revert"><%:revert Verwerfen%></a></li>
<% else %>
- <li><%:changes Änderungen: %> 0</li>
+ <li><%:changes Änderungen%>: 0</li>
<% end %>
</ul>
</div>