summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-08-09 02:45:31 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-08-09 02:45:31 +0000
commitd1fb1f9d69c865956d1a92aba6d69712ea24c741 (patch)
tree706fa87eafcbda988a1a447590ada0464a7b552f /contrib
parentd2c7747851945f77dd6327bd0afb7415be5d1c4d (diff)
contrib: add iwinfo to the package feed
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 6f4f6980e..b5b6c6281 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -236,6 +236,16 @@ define Package/luci-luanet/install
endef
+define Package/luci-iwinfo
+ $(call Package/luci/libtemplate)
+ TITLE:=Wireless abstration library
+endef
+
+define Package/luci-iwinfo/install
+ $(call Package/luci/install/template,$(1),libs/iwinfo)
+endef
+
+
define Package/luci-lucid
$(call Package/luci/libtemplate)
TITLE:=LuCId Superserver
@@ -958,6 +968,9 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-luanet),)
PKG_SELECTED_MODULES+=libs/luanet
endif
+ifneq ($(CONFIG_PACKAGE_luci-iwinfo),)
+ PKG_SELECTED_MODULES+=libs/iwinfo
+endif
ifneq ($(CONFIG_PACKAGE_luci-lucid),)
PKG_SELECTED_MODULES+=libs/lucid libs/lucid-http
endif
@@ -1165,6 +1178,7 @@ $(eval $(call BuildPackage,luci-ipkg))
$(eval $(call BuildPackage,luci-json))
$(eval $(call BuildPackage,luci-lmo))
$(eval $(call BuildPackage,luci-luanet))
+$(eval $(call BuildPackage,luci-iwinfo))
$(eval $(call BuildPackage,luci-lucid))
$(eval $(call BuildPackage,luci-nixio))
$(eval $(call BuildPackage,luci-px5g))