summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-12 05:22:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-12 05:22:38 +0000
commitb6358aaea4e997d2d2466139e702c7951bd29d7b (patch)
tree916ad5b0b9481841e2a77078c2b259ec67e81769 /contrib
parent719fd249aa6a3bbcb4efd3c130e92741cd1a4852 (diff)
libs: merge libs/http into libs/web
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile20
1 files changed, 3 insertions, 17 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index d38a1ac18..70c76486a 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -179,20 +179,10 @@ define Package/luci-fastindex/install
endef
-define Package/luci-http
- $(call Package/luci/libtemplate)
- TITLE:=HTTP Protocol implementation
-endef
-
-define Package/luci-http/install
- $(call Package/luci/install/template,$(1),libs/http)
-endef
-
-
define Package/luci-httpclient
$(call Package/luci/libtemplate)
TITLE:=HTTP(S) client library
- DEPENDS+=+luci-http +luci-nixio
+ DEPENDS+=+luci-web +luci-nixio
endef
define Package/luci-httpclient/install
@@ -244,7 +234,7 @@ endef
define Package/luci-lucid
$(call Package/luci/webservertemplate)
TITLE:=LuCId Full-Stack Webserver
- DEPENDS+=+luci-nixio +luci-http +luci-px5g
+ DEPENDS+=+luci-nixio +luci-web +luci-px5g
endef
define Package/luci-lucid/install
@@ -325,7 +315,7 @@ endef
define Package/luci-web
$(call Package/luci/libtemplate)
- DEPENDS+=+luci-http +luci-sys +luci-nixio +luci-uci \
+ DEPENDS+=+luci-sys +luci-nixio +luci-uci \
+luci-sgi-cgi +luci-lmo
TITLE:=MVC Webframework
$(call Config,luci.main.lang,string,auto,Default Language)
@@ -1061,9 +1051,6 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-fastindex),)
PKG_SELECTED_MODULES+=libs/fastindex
endif
-ifneq ($(CONFIG_PACKAGE_luci-http),)
- PKG_SELECTED_MODULES+=libs/http
-endif
ifneq ($(CONFIG_PACKAGE_luci-httpclient),)
PKG_SELECTED_MODULES+=libs/httpclient
endif
@@ -1297,7 +1284,6 @@ MAKE_FLAGS += \
$(eval $(call BuildPackage,luci-core))
$(eval $(call BuildPackage,luci-fastindex))
-$(eval $(call BuildPackage,luci-http))
$(eval $(call BuildPackage,luci-httpclient))
$(eval $(call BuildPackage,luci-ipkg))
$(eval $(call BuildPackage,luci-json))