summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-01-17 16:35:02 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-01-17 16:35:02 +0000
commit89c8f98b12f28caf95989d99da6b6cb411f979c5 (patch)
treec438471ace8fbac62b400df7c585a21c6ba76cbc /contrib
parentf2148a5c65fa6c66d0d22fa43ec2f3e71aac9aa1 (diff)
build: add mkversion.sh helper script
contrib: (re-)generate version.lua at build time libs/core: use version.lua themes: adept header to version.lua, fix css for openwrt.org
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 3016adf73..06ec7c802 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -106,6 +106,11 @@ endef
define Package/luci-core/install
$(call Package/luci/install/template,$(1),libs/core)
+ $(PKG_BUILD_DIR)/build/mkversion.sh $(1)/usr/lib/lua/luci/version.lua \
+ "OpenWrt Firmware" \
+ "$(OPENWRTVERSION)" \
+ "$(PKG_BRANCH)" \
+ "$(PKG_VERSION)"
endef
define Package/luci-core/config