summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-07-17 20:27:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-07-17 20:27:05 +0000
commit820f11932f548182ebb32704e1df83b78e69b19e (patch)
treece56e5183f28520ce6078aa5fd723d8bb3f2b310 /contrib
parent768bf67b867df0fde2715308eef482cb677a8566 (diff)
[PATCH] add tools to scan network for any device, or for sip devices, and output device information, thanks cshore
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 361bff9b2..69263e78b 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -520,6 +520,49 @@ define Package/luci-app-statistics/install
$(call Package/luci/install/template,$(1),applications/luci-statistics)
endef
+define Package/luci-app-diag-core
+ $(call Package/luci/webtemplate)
+ DEPENDS+=+luci-admin-core
+ TITLE:=LuCI Diagnostics Tools (Core)
+endef
+
+define Package/luci-app-diag-devinfo
+ $(call Package/luci/webtemplate)
+ DEPENDS+=+luci-app-diag-core +smap +netdiscover +mac-to-devinfo +httping +smap-to-devinfo +netdiscover-to-devinfo
+ TITLE:=LuCI Diagnostics Tools (Device Info)
+endef
+
+define Package/luci-app-voice-core
+ $(call Package/luci/webtemplate)
+ DEPENDS+=+luci-admin-core
+ TITLE:=LuCI Voice Software (Core)
+endef
+
+define Package/luci-app-voice-diag
+ $(call Package/luci/webtemplate)
+ DEPENDS+=+luci-app-voice-core +luci-app-diag-devinfo
+ TITLE:=LuCI Voice Software (Diagnostics)
+endef
+
+define Package/luci-app-diag-devinfo/conffiles
+/etc/config/luci_devinfo
+endef
+
+define Package/luci-app-diag-core/install
+ $(call Package/luci/install/template,$(1),applications/luci-diag-core)
+endef
+
+define Package/luci-app-diag-devinfo/install
+ $(call Package/luci/install/template,$(1),applications/luci-diag-devinfo)
+endef
+
+define Package/luci-app-voice-core/install
+ $(call Package/luci/install/template,$(1),applications/luci-voice-core)
+endef
+
+define Package/luci-app-voice-diag/install
+ $(call Package/luci/install/template,$(1),applications/luci-voice-diag)
+endef
define Package/luci-app-upnp
$(call Package/luci/webtemplate)
@@ -978,6 +1021,18 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-app-statistics),)
PKG_SELECTED_MODULES+=applications/luci-statistics
endif
+ifneq ($(CONFIG_PACKAGE_luci-app-voice-core),)
+ PKG_SELECTED_MODULES+=applications/luci-voice-core
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-voice-diag),)
+ PKG_SELECTED_MODULES+=applications/luci-voice-diag
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-diag-core),)
+ PKG_SELECTED_MODULES+=applications/luci-diag-core
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-diag-devinfo),)
+ PKG_SELECTED_MODULES+=applications/luci-diag-devinfo
+endif
ifneq ($(CONFIG_PACKAGE_luci-app-upnp),)
PKG_SELECTED_MODULES+=applications/luci-upnp
endif
@@ -1133,6 +1188,10 @@ $(eval $(call BuildPackage,luci-app-olsr))
$(eval $(call BuildPackage,luci-app-qos))
$(eval $(call BuildPackage,luci-app-splash))
$(eval $(call BuildPackage,luci-app-statistics))
+$(eval $(call BuildPackage,luci-app-diag-core))
+$(eval $(call BuildPackage,luci-app-diag-devinfo))
+$(eval $(call BuildPackage,luci-app-voice-core))
+$(eval $(call BuildPackage,luci-app-voice-diag))
$(eval $(call BuildPackage,luci-app-upnp))
$(eval $(call BuildPackage,luci-app-ntpc))
$(eval $(call BuildPackage,luci-app-ddns))