summaryrefslogtreecommitdiffhomepage
path: root/contrib/uci
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-11-14 13:41:31 +0000
committerSteven Barth <steven@midlink.org>2009-11-14 13:41:31 +0000
commitb882bdeb04adc817a477009c689ec3b79151bf71 (patch)
tree9d3f417cdbe9f66346083c507467411985e70a5e /contrib/uci
parent0784b7b9d512602f519aa7c0e826f97ef5ca25ff (diff)
Avoid unnecessary compiling
Diffstat (limited to 'contrib/uci')
-rw-r--r--contrib/uci/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile
index 04aa38b3a..b39278789 100644
--- a/contrib/uci/Makefile
+++ b/contrib/uci/Makefile
@@ -20,12 +20,10 @@ include ../../build/module.mk
$(UCI_FILE):
wget -O $@ "$(UCI_URL)" || rm -f $@
-$(UCI_PATCHDIR)/series:
- (cd $(UCI_PATCHDIR); ls *.patch | sort > series)
-
-$(UCI_DIR)/.prepared: $(UCI_PATCHDIR)/series $(UCI_FILE)
+$(UCI_DIR)/.prepared: $(UCI_FILE)
rm -rf $(UCI_DIR)
tar xvfz $(UCI_FILE)
+ (cd $(UCI_PATCHDIR); ls *.patch | sort > series) || true
[ -f "$(UCI_PATCHDIR)/series" ] && while read patch; do \
patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
done < $(UCI_PATCHDIR)/series || true