summaryrefslogtreecommitdiffhomepage
path: root/contrib/uci
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-10-26 13:33:44 +0000
committerSteven Barth <steven@midlink.org>2009-10-26 13:33:44 +0000
commit9bb9cc378bd91e5983936326260316cd6c4332a9 (patch)
tree590f81717adf38b7cbf46c3faa9fe3b0357d886c /contrib/uci
parent6e7c32fa7d5dcd0d02aac85dbe1ed10a75a72ee9 (diff)
UCI contrib patch handling
Diffstat (limited to 'contrib/uci')
-rw-r--r--contrib/uci/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile
index 19625aa72..04aa38b3a 100644
--- a/contrib/uci/Makefile
+++ b/contrib/uci/Makefile
@@ -23,9 +23,12 @@ $(UCI_FILE):
$(UCI_PATCHDIR)/series:
(cd $(UCI_PATCHDIR); ls *.patch | sort > series)
-$(UCI_DIR)/.prepared: $(UCI_FILE)
+$(UCI_DIR)/.prepared: $(UCI_PATCHDIR)/series $(UCI_FILE)
rm -rf $(UCI_DIR)
tar xvfz $(UCI_FILE)
+ [ -f "$(UCI_PATCHDIR)/series" ] && while read patch; do \
+ patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
+ done < $(UCI_PATCHDIR)/series || true
touch $@
compile: $(UCI_DIR)/.prepared