summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-11-24 10:43:08 +0000
committerSteven Barth <steven@midlink.org>2009-11-24 10:43:08 +0000
commit9692e933ef37766fc7ad58a530047e3e95d835ae (patch)
tree695b0b9b4cdb73fdc46d294c69845f27e7d58cd3 /contrib/package
parentf541da8051673a9a1b7ddd358620edcbe034de6e (diff)
Revised Makefiles a bit
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/cyassl-luci/Makefile6
-rw-r--r--contrib/package/luci/Makefile36
2 files changed, 33 insertions, 9 deletions
diff --git a/contrib/package/cyassl-luci/Makefile b/contrib/package/cyassl-luci/Makefile
index e156a82aa..98bba4115 100644
--- a/contrib/package/cyassl-luci/Makefile
+++ b/contrib/package/cyassl-luci/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
PKG_BASENAME:=cyassl
PKG_NAME:=$(PKG_BASENAME)-luci
-PKG_VERSION:=1.1.0
+PKG_VERSION:=1.2.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_BASENAME)-$(PKG_VERSION).zip
PKG_SOURCE_URL:=http://www.yassl.com/
-PKG_MD5SUM:=938341f20d7ddcba157c4ee5b00244d0
+PKG_MD5SUM:=de12e76b3faf760107e45af487adcbde
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/$(PKG_BASENAME)-$(PKG_VERSION)
PKG_UNPACK=unzip -d $(BUILD_DIR)/$(PKG_NAME) $(DL_DIR)/$(PKG_SOURCE)
@@ -29,7 +29,7 @@ define Package/libcyassl-luci
$(call Package/cyassl-luci/Default)
SECTION:=luci
CATEGORY:=LuCI
- SUBMENU:=Libraries
+ SUBMENU:=Internal Libraries
TITLE+= (library)
endef
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index d55b60d14..709828122 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -60,10 +60,15 @@ define Package/luci/libtemplate
TITLE:=LuCI - Lua Configuration Interface
URL:=http://luci.freifunk-halle.net/
MAINTAINER:=Steven Barth <steven-at-midlink-dot-org>
- SUBMENU:=Libraries
+ SUBMENU:=Internal Libraries
DEPENDS:=+luci-core
endef
+define Package/luci/webservertemplate
+ $(call Package/luci/libtemplate)
+ SUBMENU:=Webserver
+endef
+
define Package/luci/fftemplate
$(call Package/luci/libtemplate)
SUBMENU:=Freifunk
@@ -82,6 +87,11 @@ define Package/luci/thtemplate
DEPENDS:=+luci-web
endef
+define Package/luci/maintemplate
+ $(call Package/luci/libtemplate)
+ SUBMENU:=
+endef
+
define Package/luci/webtemplate
$(call Package/luci/libtemplate)
SUBMENU:=Components
@@ -253,8 +263,8 @@ endef
define Package/luci-lucid
- $(call Package/luci/libtemplate)
- TITLE:=LuCId Superserver
+ $(call Package/luci/webservertemplate)
+ TITLE:=LuCId Full-Stack Webserver
DEPENDS+=+luci-nixio +luci-http +luci-px5g
endef
@@ -331,7 +341,7 @@ define Package/luci-web
$(call Package/luci/libtemplate)
DEPENDS+=+luci-http +luci-sys +luci-uci +luci-lucid +luci-sgi-cgi +luci-lmo
TITLE:=MVC Webframework
- $(call Config,luci.main.lang,string,en,Default Language)
+ $(call Config,luci.main.lang,string,auto,Default Language)
endef
define Package/luci-web/conffiles
@@ -393,6 +403,16 @@ define Package/luci-admin-core/install
endef
+define Package/luci-niu
+ $(call Package/luci/maintemplate)
+ DEPENDS+=+luci-admin-core @BROKEN
+ TITLE:=NIU - Next Generation Interface
+endef
+
+define Package/luci-niu/install
+ $(call Package/luci/install/template,$(1),modules/niu)
+endef
+
define Package/luci-admin-mini
$(call Package/luci/webtemplate)
DEPENDS+=+luci-admin-core
@@ -759,8 +779,8 @@ endef
### Server Gateway Interfaces ###
define Package/luci-sgi-cgi
- $(call Package/luci/libtemplate)
- TITLE:=SGI for CGI
+ $(call Package/luci/webservertemplate)
+ TITLE:=CGI Gateway behind existing Webserver
endef
define Package/luci-sgi-cgi/install
@@ -1039,6 +1059,9 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-admin-full),)
PKG_SELECTED_MODULES+=modules/admin-full
endif
+ifneq ($(CONFIG_PACKAGE_luci-niu),)
+ PKG_SELECTED_MODULES+=modules/niu
+endif
ifneq ($(CONFIG_PACKAGE_luci-admin-rpc),)
PKG_SELECTED_MODULES+=modules/rpc
endif
@@ -1230,6 +1253,7 @@ $(eval $(call BuildPackage,luci-uvl))
$(eval $(call BuildPackage,luci-admin-core))
$(eval $(call BuildPackage,luci-admin-mini))
$(eval $(call BuildPackage,luci-admin-full))
+$(eval $(call BuildPackage,luci-niu))
$(eval $(call BuildPackage,luci-admin-rpc))
$(eval $(call BuildPackage,luci-mod-freifunk))