summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-09 07:56:20 +0000
committerSteven Barth <steven@midlink.org>2008-06-09 07:56:20 +0000
commit64806f32bea453b9a6fc5c4cf4c4b751a749e369 (patch)
treefa8916e368bebfdbb07451928d8aa119214945fd /contrib/package
parent004213483340028437736f5810bd1c2274b7b72c (diff)
* Made Makefiles attribute aware
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/luci/Makefile11
-rwxr-xr-xcontrib/package/luci/ipkg/luci-ff-halle.postinst4
-rwxr-xr-xcontrib/package/luci/ipkg/luci-ff-hannover.postinst4
-rwxr-xr-xcontrib/package/luci/ipkg/luci-ff-leipzig.postinst4
-rwxr-xr-xcontrib/package/luci/ipkg/luci-sgi-haserl.postinst9
-rwxr-xr-xcontrib/package/luci/ipkg/luci-statistics.postint4
6 files changed, 2 insertions, 34 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index b438760f5..7557c827e 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -62,7 +62,8 @@ endef
define Package/luci/install/template
- $(CP) $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
+ $(CP) -a $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
+ $(CP) -a $(PKG_BUILD_DIR)/$(2)/ipkg/* $(1)/CONTROL/ 2>/dev/null || true
endef
@@ -163,7 +164,6 @@ endef
define Package/luci-ff-halle/install
$(call Package/luci/install/template,$(1),applications/community-halle)
- $(CP) -a ./ipkg/luci-ff-halle.postinst $(1)/CONTROL/postinst
endef
@@ -181,7 +181,6 @@ endef
define Package/luci-ff-leipzig/install
$(call Package/luci/install/template,$(1),applications/community-leipzig)
- $(CP) -a ./ipkg/luci-ff-leipzig.postinst $(1)/CONTROL/postinst
endef
@@ -199,7 +198,6 @@ endef
define Package/luci-ff-hannover/install
$(call Package/luci/install/template,$(1),applications/community-hannover)
- $(CP) -a ./ipkg/luci-ff-hannover.postinst $(1)/CONTROL/postinst
endef
@@ -257,7 +255,6 @@ endef
define Package/luci-app-firewall/install
$(call Package/luci/install/template,$(1),applications/luci-fw)
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-fw/dist/etc/init.d/luci_fw $(1)/etc/init.d
endef
@@ -315,9 +312,6 @@ endef
define Package/luci-app-statistics/install
$(call Package/luci/install/template,$(1),applications/luci-statistics)
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/usr/bin/stat-genconfig $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/etc/init.d/luci_statistics $(1)/etc/init.d
- $(CP) -a ./ipkg/luci-statistics.postinst $(1)/CONTROL/postinst
endef
@@ -331,7 +325,6 @@ endef
define Package/luci-sgi-haserl/install
$(call Package/luci/install/template,$(1),libs/sgi-haserl)
- $(CP) -a ./ipkg/luci-sgi-haserl.postinst $(1)/CONTROL/postinst
endef
diff --git a/contrib/package/luci/ipkg/luci-ff-halle.postinst b/contrib/package/luci/ipkg/luci-ff-halle.postinst
deleted file mode 100755
index 0efb5a9a7..000000000
--- a/contrib/package/luci/ipkg/luci-ff-halle.postinst
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
- ( . /etc/uci-defaults/luci-community-halle ) && rm -f /etc/uci-defaults/luci-community-halle
-}
diff --git a/contrib/package/luci/ipkg/luci-ff-hannover.postinst b/contrib/package/luci/ipkg/luci-ff-hannover.postinst
deleted file mode 100755
index b41179f72..000000000
--- a/contrib/package/luci/ipkg/luci-ff-hannover.postinst
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
- ( . /etc/uci-defaults/luci-community-hannover ) && rm -f /etc/uci-defaults/luci-community-hannover
-}
diff --git a/contrib/package/luci/ipkg/luci-ff-leipzig.postinst b/contrib/package/luci/ipkg/luci-ff-leipzig.postinst
deleted file mode 100755
index 5aff5db95..000000000
--- a/contrib/package/luci/ipkg/luci-ff-leipzig.postinst
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
- ( . /etc/uci-defaults/luci-community-leipzig ) && rm -f /etc/uci-defaults/luci-community-leipzig
-}
diff --git a/contrib/package/luci/ipkg/luci-sgi-haserl.postinst b/contrib/package/luci/ipkg/luci-sgi-haserl.postinst
deleted file mode 100755
index 483a0867a..000000000
--- a/contrib/package/luci/ipkg/luci-sgi-haserl.postinst
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-PATTERNS='/cgi-bin/luci/admin:root:$p$root /cgi-bin/luci-upload:root:$p$root'
-
-for i in $PATTERNS
-do
- grep "$i" ${IPKG_INSTROOT}/etc/httpd.conf >/dev/null 2>/dev/null || echo "$i" >> ${IPKG_INSTROOT}/etc/httpd.conf
-done
-
-[ -n ${IPKG_INSTROOT} ] || /etc/init.d/httpd restart
diff --git a/contrib/package/luci/ipkg/luci-statistics.postint b/contrib/package/luci/ipkg/luci-statistics.postint
deleted file mode 100755
index 69fe0c016..000000000
--- a/contrib/package/luci/ipkg/luci-statistics.postint
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
- ( . /etc/uci-defaults/luci-statistics ) && rm -f /etc/uci-defaults/luci-statistics
-}