summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/freifunk-firewall/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-06-16 22:38:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-06-16 22:38:38 +0000
commit604afe9bc91dca43e735d0609b60f365769419e9 (patch)
treeb3bcde4b6c650047854c4b53b69e52aaa46e7a0c /contrib/package/freifunk-firewall/Makefile
parent720e460893b2d83d76715786075e03787216750a (diff)
contrib/package: add separate freifunk-firewall package
Diffstat (limited to 'contrib/package/freifunk-firewall/Makefile')
-rw-r--r--contrib/package/freifunk-firewall/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/contrib/package/freifunk-firewall/Makefile b/contrib/package/freifunk-firewall/Makefile
new file mode 100644
index 000000000..d2ae07588
--- /dev/null
+++ b/contrib/package/freifunk-firewall/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2009 Jo-Philipp Wich <xm@subsignal.org>
+#
+# This is free software, licensed under the Apache 2.0 license.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=freifunk-firewall
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/freifunk-firewall
+ SECTION:=luci
+ CATEGORY:=LuCI
+ SUBMENU:=Freifunk
+ TITLE:=Freifunk Firewall Addon
+ DEPENDS:=+firewall
+endef
+
+define Package/freifunk-firewall/description
+ Various firewall extensions for Freifunk. Includes NAT fixes and advanced settings.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/freifunk-firewall/postinst
+#!/bin/sh
+
+if ! grep -q /etc/firewall.freifunk /etc/config/firewall; then
+ uci add firewall include >/dev/null
+ uci set firewall.@include[-1].path=/etc/firewall.freifunk
+ uci commit firewall
+fi
+endef
+
+define Package/freifunk-firewall/install
+ $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,freifunk-firewall))