summaryrefslogtreecommitdiffhomepage
path: root/build/i18n-add-language.sh
diff options
context:
space:
mode:
authorPaul Donald <newtwen+github@gmail.com>2024-10-21 23:33:36 +0200
committerPaul Donald <newtwen+github@gmail.com>2024-10-22 00:49:01 +0200
commitdc44c7a68ee4522189ad86cd33824dc68c9600c4 (patch)
treee8615cc442ec0aa5d4e6551f030ff5f1a1e9507b /build/i18n-add-language.sh
parent24bbea6825bc5ae2713270a1c2e206cc0212343e (diff)
build: co-opt i18n-init.sh to kick start an empty app folder
Signed-off-by: Paul Donald <newtwen+github@gmail.com>
Diffstat (limited to 'build/i18n-add-language.sh')
-rwxr-xr-xbuild/i18n-add-language.sh6
1 files changed, 3 insertions, 3 deletions
diff --git a/build/i18n-add-language.sh b/build/i18n-add-language.sh
index 951985253e..d244e71c0c 100755
--- a/build/i18n-add-language.sh
+++ b/build/i18n-add-language.sh
@@ -2,7 +2,7 @@
LANGS=$@
if [ "$#" -eq 0 ]; then
- echo $0 "adds i18n catalogue(s) in po/ folders (luci-app-*, luci-mod-*, etc) for each LUCI_LANG.* in luci.mk"
+ echo $(basename "$0") "adds i18n catalogue(s) in po/ folders (luci-app-*, luci-mod-*, etc) for each LUCI_LANG.* in luci.mk"
echo "Hint: run in the root of the luci repo or in your luci-app-* folder."
# get existing language codes from luci.mk
@@ -14,8 +14,8 @@ else
case "$LANG" in
[a-z][a-z]|[a-z][a-z][_-][A-Za-z][A-Za-z]*) : ;;
*)
- echo $0 "adds i18n catalogues in each folder (luci-app-*, luci-mod-*, etc)."
- echo "Usage: $0 <ISO_CODE> [<ISO_CODE> <ISO_CODE> ...]" >&2
+ echo $(basename "$0") "adds i18n catalogues in each folder (luci-app-*, luci-mod-*, etc)."
+ echo "Usage: $(basename "$0") <ISO_CODE> [<ISO_CODE> <ISO_CODE> ...]" >&2
exit 1
;;
esac