summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.net>2021-10-06 14:50:14 -0700
committerGitHub <noreply@github.com>2021-10-06 14:50:14 -0700
commite5442bbc8bbf6d0948bdda1c461c623cd41a33cd (patch)
treebda1697805f8da9317f475909d4c55f4dc50620a /applications
parentc8d9819c9a54eb4854157bd1eb0f9c540621b2b4 (diff)
parentc939330e95e5e62dae70eae33853c83547a69994 (diff)
Merge pull request #5412 from stangri/master-luci-app-advanced-reboot
luci-app-advanced-reboot: bugfix for Linksys E4200v2
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile2
-rw-r--r--applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js2
-rwxr-xr-xapplications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot2
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-e4200v2.json5
4 files changed, 7 insertions, 4 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index a0024cdc1f..114d1cd859 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
-PKG_VERSION:=1.0.1-2
+PKG_VERSION:=1.0.1-3
LUCI_TITLE:=Advanced Linksys Reboot Web UI
LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
diff --git a/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js b/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
index f4acb8285d..482b8e2e91 100644
--- a/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
+++ b/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
@@ -197,7 +197,7 @@ return view.extend({
if (device_info.error)
body.appendChild(E('p', { 'class' : 'alert-message warning'}, _("ERROR: ") + this.translateTable[device_info.error]()));
- body.appendChild(E('h3', device_info.device_name + _(' Partitions')));
+ body.appendChild(E('h3', (device_info.device_name || '') + _(' Partitions')));
if (device_info.device_name) {
var partitions_table = E('table', { 'class': 'table' }, [
E('tr', { 'class': 'tr table-titles' }, [
diff --git a/applications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot b/applications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot
index 7ee2ec8ba2..7ec52a3097 100755
--- a/applications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot
+++ b/applications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot
@@ -1,6 +1,6 @@
#!/bin/sh
# Copyright 2017-2020 Stan Grishin (stangri@melmac.net)
-# shellcheck disable=SC2039,SC1091
+# shellcheck disable=SC2039,SC1091,SC3043,SC3057,SC3060
readonly devices_dir="/usr/share/advanced-reboot/devices/"
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-e4200v2.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-e4200v2.json
index c32aaf8a3c..d42319e2ce 100644
--- a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-e4200v2.json
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-e4200v2.json
@@ -1,7 +1,10 @@
{
"vendorName": "Linksys",
"deviceName": "E4200v2",
- "boardNames": [ "linksys-e4200v2", "linksys,e4200v2" ],
+ "boardNames": [
+ "linksys-e4200v2",
+ "linksys,e4200-v2"
+ ],
"partition1MTD": "mtd3",
"partition2MTD": "mtd5",
"labelOffset": 32,