summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2024-03-18 15:42:06 +0100
committerGitHub <noreply@github.com>2024-03-18 15:42:06 +0100
commit6b5c400c7bcd92632a134b3e80e7c15c16350578 (patch)
treed76c7df1e50bef754fabf117e218fb578e1f65ee /applications
parentf2a49104c4839cc61c0c6a32cf0b616ca7b7d667 (diff)
parenta5d7ce06f96436dcf02970d5df8c68b65968e37c (diff)
Merge pull request #6998 from dannil/dockerman-networks-null
luci-app-dockerman: check for existing IPAM config
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-dockerman/Makefile2
-rw-r--r--applications/luci-app-dockerman/luasrc/model/cbi/dockerman/networks.lua4
2 files changed, 3 insertions, 3 deletions
diff --git a/applications/luci-app-dockerman/Makefile b/applications/luci-app-dockerman/Makefile
index 72ec1d97b3..f49be3c7cc 100644
--- a/applications/luci-app-dockerman/Makefile
+++ b/applications/luci-app-dockerman/Makefile
@@ -12,7 +12,7 @@ PKG_LICENSE:=AGPL-3.0
PKG_MAINTAINER:=lisaac <lisaac.cn@gmail.com> \
Florian Eckert <fe@dev.tdt.de>
-PKG_VERSION:=v0.5.13-20230114
+PKG_VERSION:=v0.5.13-20240317
include ../../luci.mk
diff --git a/applications/luci-app-dockerman/luasrc/model/cbi/dockerman/networks.lua b/applications/luci-app-dockerman/luasrc/model/cbi/dockerman/networks.lua
index 007e087424..f54acbd16d 100644
--- a/applications/luci-app-dockerman/luasrc/model/cbi/dockerman/networks.lua
+++ b/applications/luci-app-dockerman/luasrc/model/cbi/dockerman/networks.lua
@@ -38,8 +38,8 @@ local get_networks = function ()
data[index]["_interface"] = v.Options.parent
end
- data[index]["_subnet"] = v.IPAM and v.IPAM.Config[1] and v.IPAM.Config[1].Subnet or nil
- data[index]["_gateway"] = v.IPAM and v.IPAM.Config[1] and v.IPAM.Config[1].Gateway or nil
+ data[index]["_subnet"] = v.IPAM and v.IPAM.Config and v.IPAM.Config[1] and v.IPAM.Config[1].Subnet or nil
+ data[index]["_gateway"] = v.IPAM and v.IPAM.Config and v.IPAM.Config[1] and v.IPAM.Config[1].Gateway or nil
end
return data