summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2024-07-29 14:35:00 -0700
committerGitHub <noreply@github.com>2024-07-29 14:35:00 -0700
commit52bbc55f6d911dfa57b6d0c6482a212775f5cfda (patch)
tree1dd73924ef16e312416e20a53e0ba80fa1a88a05 /applications
parent975b5d3ad668bbb31f342a22de3e6f1b89ef7b1e (diff)
parent9c836d14734f069421a459a63436d07cc91dd760 (diff)
Merge pull request #7215 from stangri/master-luci-app-https-dns-proxy
luci-app-https-dns-proxy: bugfix: OpenDNS family filter URL update
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-https-dns-proxy/Makefile9
-rw-r--r--applications/luci-app-https-dns-proxy/README.md4
-rw-r--r--applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/https-dns-proxy/status.js15
-rw-r--r--applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js29
-rw-r--r--applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js54
-rw-r--r--applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot13
-rw-r--r--applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.opendns.doh.json4
7 files changed, 34 insertions, 94 deletions
diff --git a/applications/luci-app-https-dns-proxy/Makefile b/applications/luci-app-https-dns-proxy/Makefile
index f546806849..9ca8811899 100644
--- a/applications/luci-app-https-dns-proxy/Makefile
+++ b/applications/luci-app-https-dns-proxy/Makefile
@@ -1,15 +1,16 @@
-# Copyright 2017-2018 Stan Grishin (stangri@melmac.ca)
-# This is free software, licensed under the GNU General Public License v3.
+# Copyright 2017-2024 MOSSDeF, Stan Grishin (stangri@melmac.ca).
+# This is free software, licensed under AGPL-3.0-or-later.
include $(TOPDIR)/rules.mk
PKG_NAME:=luci-app-https-dns-proxy
-PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE:=AGPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
PKG_VERSION:=2023.11.19
-PKG_RELEASE:=r3
+PKG_RELEASE:=4
LUCI_TITLE:=DNS Over HTTPS Proxy Web UI
+LUCI_URL:=https://github.com/stangri/luci-app-https-dns-proxy/
LUCI_DESCRIPTION:=Provides Web UI for DNS Over HTTPS Proxy
LUCI_DEPENDS:=+luci-base +https-dns-proxy
diff --git a/applications/luci-app-https-dns-proxy/README.md b/applications/luci-app-https-dns-proxy/README.md
new file mode 100644
index 0000000000..a9e965270b
--- /dev/null
+++ b/applications/luci-app-https-dns-proxy/README.md
@@ -0,0 +1,4 @@
+# README
+
+Documentation for this project is available at [https://docs.openwrt.melmac.net/luci-app-https-dns-proxy/](https://docs.openwrt.melmac.net/luci-app-https-dns-proxy/).
+
diff --git a/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/https-dns-proxy/status.js b/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/https-dns-proxy/status.js
index 0ae128b923..37675c5b83 100644
--- a/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/https-dns-proxy/status.js
+++ b/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/https-dns-proxy/status.js
@@ -13,8 +13,16 @@ var pkg = {
get Name() {
return "https-dns-proxy";
},
+ get ReadmeCompat() {
+ return "";
+ },
get URL() {
- return "https://docs.openwrt.melmac.net/" + pkg.Name + "/";
+ return (
+ "https://docs.openwrt.melmac.net/" +
+ pkg.Name +
+ "/" +
+ (pkg.ReadmeCompat ? pkg.ReadmeCompat + "/" : "")
+ );
},
templateToRegexp: function (template) {
return RegExp(
@@ -30,6 +38,9 @@ var pkg = {
"$"
);
},
+ templateToResolver: function (template, args) {
+ return template.replace(/{(\w+)}/g, (_, v) => args[v]);
+ },
};
var getInitList = rpc.declare({
@@ -428,6 +439,8 @@ RPC.on("setInitAction", function (reply) {
return L.Class.extend({
status: status,
+ pkg: pkg,
+ getInitStatus: getInitStatus,
getPlatformSupport: getPlatformSupport,
getProviders: getProviders,
getRuntime: getRuntime,
diff --git a/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js b/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js
index 86cafd1030..5922a35279 100644
--- a/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js
+++ b/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js
@@ -11,34 +11,7 @@
"require view";
"require https-dns-proxy.status as hdp";
-var pkg = {
- get Name() {
- return "https-dns-proxy";
- },
-
- get URL() {
- return "https://docs.openwrt.melmac.net/" + pkg.Name + "/";
- },
-
- templateToRegexp: function (template) {
- return RegExp(
- "^" +
- template
- .split(/(\{\w+\})/g)
- .map((part) => {
- let placeholder = part.match(/^\{(\w+)\}$/);
- if (placeholder) return `(?<${placeholder[1]}>.*?)`;
- else return part.replace(/[.*+?^${}()|[\]\\]/g, "\\$&");
- })
- .join("") +
- "$"
- );
- },
-
- templateToResolver: function (template, args) {
- return template.replace(/{(\w+)}/g, (_, v) => args[v]);
- },
-};
+var pkg = hdp.pkg;
return view.extend({
load: function () {
diff --git a/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js b/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js
index 8723b6e653..401e1546d1 100644
--- a/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js
+++ b/applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js
@@ -3,62 +3,18 @@
"require uci";
"require form";
"require baseclass";
+"require https-dns-proxy.status as hdp";
-var pkg = {
- get Name() {
- return "https-dns-proxy";
- },
- get URL() {
- return "https://docs.openwrt.melmac.net/" + pkg.Name + "/";
- },
- templateToRegexp: function (template) {
- return RegExp(
- "^" +
- template
- .split(/(\{\w+\})/g)
- .map((part) => {
- let placeholder = part.match(/^\{(\w+)\}$/);
- if (placeholder) return `(?<${placeholder[1]}>.*?)`;
- else return part.replace(/[.*+?^${}()|[\]\\]/g, "\\$&");
- })
- .join("") +
- "$"
- );
- },
-};
-
-var getInitStatus = rpc.declare({
- object: "luci." + pkg.Name,
- method: "getInitStatus",
- params: ["name"],
-});
-
-var getPlatformSupport = rpc.declare({
- object: "luci." + pkg.Name,
- method: "getPlatformSupport",
- params: ["name"],
-});
-
-var getProviders = rpc.declare({
- object: "luci." + pkg.Name,
- method: "getProviders",
- params: ["name"],
-});
-
-var getRuntime = rpc.declare({
- object: "luci." + pkg.Name,
- method: "getRuntime",
- params: ["name"],
-});
+var pkg = hdp.pkg;
return baseclass.extend({
title: _("HTTPS DNS Proxy Instances"),
load: function () {
return Promise.all([
- getInitStatus(pkg.Name),
- getProviders(pkg.Name),
- getRuntime(pkg.Name),
+ hdp.getInitStatus(pkg.Name),
+ hdp.getProviders(pkg.Name),
+ hdp.getRuntime(pkg.Name),
]);
},
diff --git a/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot b/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
index dcd1d014bc..9267960845 100644
--- a/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
+++ b/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
@@ -131,10 +131,6 @@ msgstr ""
msgid "DeCloudUs DNS"
msgstr ""
-#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:14
-msgid "Default (Blocks ads and trackers)"
-msgstr ""
-
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ch.digitale-gesellschaft.dns.json:2
msgid "Digitale Gesellschaft (CH)"
msgstr ""
@@ -176,7 +172,7 @@ msgid "FFMUC DNS (DE)"
msgstr ""
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/ca.cira.canadianshield.json:14
-#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:22
+#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:14
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.cloudflare-dns.json:14
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.controld.freedns.json:14
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.opendns.doh.json:14
@@ -503,6 +499,7 @@ msgid "Spain"
msgstr ""
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/co.oszx.dns.json:18
+#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:18
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.cloudflare-dns.json:18
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.controld.freedns.json:18
#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.opendns.doh.json:18
@@ -536,7 +533,7 @@ msgstr ""
msgid "Switzerland"
msgstr ""
-#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js:149
+#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/status/include/71_https-dns-proxy.js:148
msgid "There are no active instances."
msgstr ""
@@ -556,10 +553,6 @@ msgstr ""
msgid "US/New York"
msgstr ""
-#: applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.adguard.dns.json:18
-msgid "Unfiltered"
-msgstr ""
-
#: applications/luci-app-https-dns-proxy/htdocs/luci-static/resources/view/https-dns-proxy/overview.js:245
msgid "Unknown"
msgstr ""
diff --git a/applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.opendns.doh.json b/applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.opendns.doh.json
index b9989d5383..cbf5ca28ac 100644
--- a/applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.opendns.doh.json
+++ b/applications/luci-app-https-dns-proxy/root/usr/share/https-dns-proxy/providers/com.opendns.doh.json
@@ -7,10 +7,10 @@
"option": {
"description": "Variant",
"type": "select",
- "regex": "(family.|)",
+ "regex": "(familyshield.|)",
"options": [
{
- "value": "family.",
+ "value": "familyshield.",
"description": "Family Filter"
},
{