summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-p2pblock
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-p2pblock
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-p2pblock')
-rw-r--r--applications/luci-p2pblock/Makefile4
-rwxr-xr-xapplications/luci-p2pblock/ipkg/postinst6
-rw-r--r--applications/luci-p2pblock/luasrc/controller/ff_p2pblock.lua20
-rw-r--r--applications/luci-p2pblock/luasrc/model/cbi/luci_fw/p2pblock.lua77
-rwxr-xr-xapplications/luci-p2pblock/root/etc/uci-defaults/luci-p2pblock11
5 files changed, 0 insertions, 118 deletions
diff --git a/applications/luci-p2pblock/Makefile b/applications/luci-p2pblock/Makefile
deleted file mode 100644
index 07ce232f8..000000000
--- a/applications/luci-p2pblock/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-PO = p2pblock
-
-include ../../build/config.mk
-include ../../build/module.mk
diff --git a/applications/luci-p2pblock/ipkg/postinst b/applications/luci-p2pblock/ipkg/postinst
deleted file mode 100755
index 448025b76..000000000
--- a/applications/luci-p2pblock/ipkg/postinst
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
- ( . /etc/uci-defaults/luci-p2pblock ) && rm -f /etc/uci-defaults/luci-p2pblock
- /etc/init.d/freifunk-p2pblock enabled || /etc/init.d/freifunk-p2pblock enable
- exit 0
-}
diff --git a/applications/luci-p2pblock/luasrc/controller/ff_p2pblock.lua b/applications/luci-p2pblock/luasrc/controller/ff_p2pblock.lua
deleted file mode 100644
index 887f18756..000000000
--- a/applications/luci-p2pblock/luasrc/controller/ff_p2pblock.lua
+++ /dev/null
@@ -1,20 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2009 Jo-Philipp Wich <xm@subsignal.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-
-module("luci.controller.ff_p2pblock", package.seeall)
-
-function index()
- entry({"admin", "network", "firewall", "p2pblock"}, cbi("luci_fw/p2pblock"),
- _("P2P-Block"), 40)
-end
diff --git a/applications/luci-p2pblock/luasrc/model/cbi/luci_fw/p2pblock.lua b/applications/luci-p2pblock/luasrc/model/cbi/luci_fw/p2pblock.lua
deleted file mode 100644
index 35f76cd2b..000000000
--- a/applications/luci-p2pblock/luasrc/model/cbi/luci_fw/p2pblock.lua
+++ /dev/null
@@ -1,77 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2009 Jo-Philipp Wich <xm@subsignal.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-
-local sys = require "luci.sys"
-
-m = Map("freifunk_p2pblock", translate("P2P-Block"),
- translate("P2P-Block is a greylisting mechanism to block various peer-to-peer protocols for non-whitelisted clients."))
-
-s = m:section(NamedSection, "p2pblock", "settings", "Settings")
-s.anonymous = true
-s.addremove = false
-
-en = s:option(Flag, "_enabled", translate("Enable P2P-Block"))
-en.rmempty = false
-
-function en.cfgvalue()
- return ( sys.init.enabled("freifunk-p2pblock") and "1" or "0" )
-end
-
-function en.write(self, section, val)
- if val == "1" then
- sys.init.enable("freifunk-p2pblock")
- else
- sys.init.disable("freifunk-p2pblock")
- end
-end
-
-s:option(Value, "portrange", translate("Portrange"))
-
-s:option(Value, "blocktime", translate("Block Time"),
- translate("seconds"))
-
-s:option(DynamicList, "whitelist", translate("Whitelisted IPs"))
-
-l7 = s:option(MultiValue, "layer7", translate("Layer7-Protocols"))
-l7.widget = "checkbox"
-l7:value("aim", "AIM Chat")
-l7:value("bittorrent", "Bittorrent")
-l7:value("edonkey", "eDonkey, eMule, Kademlia")
-l7:value("fasttrack", "Fasttrack Protocol")
-l7:value("ftp", "File Transfer Protocol")
-l7:value("gnutella", "Gnutella")
-l7:value("http", "Hypertext Transfer Protocol")
-l7:value("ident", "Ident Protocol")
-l7:value("irc", "Internet Relay Chat")
-l7:value("jabber", "Jabber/XMPP")
-l7:value("msnmessenger", "MSN Messenger")
-l7:value("ntp", "Network Time Protocol")
-l7:value("pop3", "POP3 Protocol")
-l7:value("smtp", "SMTP Protocol")
-l7:value("ssl", "SSL Protocol")
-l7:value("vnc", "VNC Protocol")
-
-ipp2p = s:option(MultiValue, "ipp2p", translate("IP-P2P"))
-ipp2p.widget = "checkbox"
-ipp2p:value("edk", "eDonkey, eMule, Kademlia")
-ipp2p:value("kazaa", "KaZaA, FastTrack")
-ipp2p:value("gnu", "Gnutella")
-ipp2p:value("dc", "Direct Connect")
-ipp2p:value("bit", "BitTorrent, extended BT")
-ipp2p:value("apple", "AppleJuice")
-ipp2p:value("winmx", "WinMX")
-ipp2p:value("soul", "SoulSeek")
-ipp2p:value("ares", "AresLite")
-
-return m
diff --git a/applications/luci-p2pblock/root/etc/uci-defaults/luci-p2pblock b/applications/luci-p2pblock/root/etc/uci-defaults/luci-p2pblock
deleted file mode 100755
index 030ebbed1..000000000
--- a/applications/luci-p2pblock/root/etc/uci-defaults/luci-p2pblock
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-uci -q batch <<-EOF >/dev/null
- delete citrack.@freifunk_p2pblock[-1]
- add ucitrack freifunk_p2pblock
- set ucitrack.@freifunk_p2pblock[-1].init=freifunk-p2pblock
- commit ucitrack
-EOF
-
-rm -f /tmp/luci-indexcache
-exit 0