summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-mjpg-streamer/luasrc/controller/mjpg-streamer.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-mjpg-streamer/luasrc/controller/mjpg-streamer.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-mjpg-streamer/luasrc/controller/mjpg-streamer.lua')
-rw-r--r--applications/luci-mjpg-streamer/luasrc/controller/mjpg-streamer.lua29
1 files changed, 0 insertions, 29 deletions
diff --git a/applications/luci-mjpg-streamer/luasrc/controller/mjpg-streamer.lua b/applications/luci-mjpg-streamer/luasrc/controller/mjpg-streamer.lua
deleted file mode 100644
index 97b9aa4abb..0000000000
--- a/applications/luci-mjpg-streamer/luasrc/controller/mjpg-streamer.lua
+++ /dev/null
@@ -1,29 +0,0 @@
---[[
-LuCI MJPEG Streamer
-
-(c) 2014 Roger D <rogerdammit@gmail.com>
-Based on work by: vargabab and OpenWrt Dreambox
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-
-module("luci.controller.mjpg-streamer", package.seeall)
-
-function index()
- require("luci.i18n")
- luci.i18n.loadc("mjpg-streamer")
- if not nixio.fs.access("/etc/config/mjpg-streamer") then
- return
- end
-
- local page = entry({"admin", "services", "mjpg-streamer"}, cbi("mjpg-streamer"), _("MJPG-streamer"))
- page.i18n = "mjpg-streamer"
- page.dependent = true
-
-end