summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-asterisk/luasrc/model/cbi/asterisk-iax-connections.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-asterisk/luasrc/model/cbi/asterisk-iax-connections.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-asterisk/luasrc/model/cbi/asterisk-iax-connections.lua')
-rw-r--r--applications/luci-asterisk/luasrc/model/cbi/asterisk-iax-connections.lua60
1 files changed, 0 insertions, 60 deletions
diff --git a/applications/luci-asterisk/luasrc/model/cbi/asterisk-iax-connections.lua b/applications/luci-asterisk/luasrc/model/cbi/asterisk-iax-connections.lua
deleted file mode 100644
index 0102c1b937..0000000000
--- a/applications/luci-asterisk/luasrc/model/cbi/asterisk-iax-connections.lua
+++ /dev/null
@@ -1,60 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2008 Steven Barth <steven@midlink.org>
-Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-
-cbimap = Map("asterisk", "asterisk", "")
-
-iax = cbimap:section(TypedSection, "iax", "IAX Connection", "")
-iax.addremove = true
-
-alwaysinternational = iax:option(Flag, "alwaysinternational", "Always Dial International", "")
-alwaysinternational.optional = true
-
-context = iax:option(ListValue, "context", "Context to use", "")
-context.titleref = luci.dispatcher.build_url( "admin", "services", "asterisk", "dialplans" )
-cbimap.uci:foreach( "asterisk", "dialplan", function(s) context:value(s['.name']) end )
-cbimap.uci:foreach( "asterisk", "dialzone", function(s) context:value(s['.name']) end )
-
-countrycode = iax:option(Value, "countrycode", "Country Code for connection", "")
-countrycode.optional = true
-
-extension = iax:option(Value, "extension", "Add as Extension", "")
-extension.optional = true
-
-host = iax:option(Value, "host", "Host name (or blank)", "")
-host.optional = true
-
-internationalprefix = iax:option(Value, "internationalprefix", "International Dial Prefix", "")
-internationalprefix.optional = true
-
-prefix = iax:option(Value, "prefix", "Dial Prefix (for external line)", "")
-prefix.optional = true
-
-secret = iax:option(Value, "secret", "Secret", "")
-secret.optional = true
-
-timeout = iax:option(Value, "timeout", "Dial Timeout (sec)", "")
-timeout.optional = true
-
-type = iax:option(ListValue, "type", "Option type", "")
-type:value("friend", "Friend (outbound/inbound)")
-type:value("user", "User (inbound - authenticate by \"from\")")
-type:value("peer", "Peer (outbound - match by host)")
-type.optional = true
-
-username = iax:option(Value, "username", "User name", "")
-username.optional = true
-
-
-return cbimap