summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-statistics/root/etc/init.d/luci_statistics
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-statistics/root/etc/init.d/luci_statistics
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-statistics/root/etc/init.d/luci_statistics')
-rwxr-xr-xapplications/luci-app-statistics/root/etc/init.d/luci_statistics33
1 files changed, 33 insertions, 0 deletions
diff --git a/applications/luci-app-statistics/root/etc/init.d/luci_statistics b/applications/luci-app-statistics/root/etc/init.d/luci_statistics
new file mode 100755
index 0000000000..936f3a63c3
--- /dev/null
+++ b/applications/luci-app-statistics/root/etc/init.d/luci_statistics
@@ -0,0 +1,33 @@
+#!/bin/sh /etc/rc.common
+START=79
+
+start() {
+ ### replace shipped config with symlink
+ if [ ! -L /etc/collectd.conf ]; then
+ test -f /etc/collectd.conf && mv /etc/collectd.conf /etc/collectd.conf.bak
+ ln -s /var/etc/collectd.conf /etc/collectd.conf
+ fi
+
+ ### create config
+ mkdir -p /var/etc
+ /usr/bin/stat-genconfig > /var/etc/collectd.conf
+
+ ### prepare rrdimg directory
+ if [ -f /etc/config/lucid ] && [ -x /etc/init.d/lucid ] && /etc/init.d/lucid enabled && \
+ [ "$(uci get luci_statistics.rrdtool.image_path 2>/dev/null)" != "$(uci get lucid.statistics.physical 2>/dev/null)" ]; then
+ uci set lucid.statistics.physical=$(uci get luci_statistics.rrdtool.image_path)
+ uci commit lucid
+ /etc/init.d/lucid restart
+ fi
+
+ ### workaround broken permissions on /tmp
+ chmod 1777 /tmp
+}
+
+restart() {
+ ### regenerate config / prepare environment
+ start
+
+ ### restart collectd
+ /etc/init.d/collectd restart
+}