summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/ping.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/ping.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/ping.lua')
-rw-r--r--applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/ping.lua41
1 files changed, 41 insertions, 0 deletions
diff --git a/applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/ping.lua b/applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/ping.lua
new file mode 100644
index 0000000000..bdffc85997
--- /dev/null
+++ b/applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/ping.lua
@@ -0,0 +1,41 @@
+--[[
+
+Luci statistics - ping plugin diagram definition
+(c) 2008 Freifunk Leipzig / Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id: ping.lua 6810 2011-01-29 03:33:48Z jow $
+
+]]--
+
+module("luci.statistics.rrdtool.definitions.ping", package.seeall)
+
+function rrdargs( graph, plugin, plugin_instance, dtype )
+ return {
+ -- Ping roundtrip time
+ { title = "%H: ICMP Round Trip Time", vlabel = "ms",
+ number_format = "%5.1lf ms", data = {
+ sources = { ping = { "value" } },
+ options = { ping__ping = { noarea = true, title = "%di" } }
+ } },
+
+ -- Ping droprate
+ { title = "%H: ICMP Drop Rate", vlabel = "%",
+ number_format = "%5.2lf %%", data = {
+ types = { "ping_droprate" },
+ options = { ping_droprate = { title = "%di" } }
+ } },
+
+ -- Ping standard deviation
+ { title = "%H: ICMP Standard Deviation", vlabel = "ms",
+ number_format = "%5.2lf ms", data = {
+ types = { "ping_stddev" },
+ options = { ping_stddev = { title = "%di" } }
+ } },
+ }
+end