summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/load.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/load.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/load.lua')
-rw-r--r--applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/load.lua36
1 files changed, 36 insertions, 0 deletions
diff --git a/applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/load.lua b/applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/load.lua
new file mode 100644
index 000000000..4cb4795ef
--- /dev/null
+++ b/applications/luci-app-statistics/luasrc/statistics/rrdtool/definitions/load.lua
@@ -0,0 +1,36 @@
+--[[
+
+Luci statistics - load plugin diagram definition
+(c) 2008 Freifunk Leipzig / Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id: load.lua 2329 2008-06-08 21:51:55Z jow $
+
+]]--
+
+module("luci.statistics.rrdtool.definitions.load", package.seeall)
+
+function rrdargs( graph, plugin, plugin_instance, dtype )
+
+ return {
+ title = "%H: Load", vlabel = "Load",
+ y_min = "0",
+ units_exponent = "0",
+ number_format = "%5.2lf", data = {
+ sources = {
+ load = { "shortterm", "midterm", "longterm" }
+ },
+
+ options = {
+ load__shortterm = { color = "ff0000", title = "1 minute", noarea = true },
+ load__midterm = { color = "ff6600", title = "5 minutes", noarea = true },
+ load__longterm = { color = "ffaa00", title = "15 minutes", noarea = true }
+ }
+ }
+ }
+end