summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/olsrd.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/olsrd.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/olsrd.lua')
-rw-r--r--applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/olsrd.lua54
1 files changed, 54 insertions, 0 deletions
diff --git a/applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/olsrd.lua b/applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/olsrd.lua
new file mode 100644
index 000000000..e3eb7b2c4
--- /dev/null
+++ b/applications/luci-app-statistics/luasrc/model/cbi/luci_statistics/olsrd.lua
@@ -0,0 +1,54 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2011 Manuel Munz <freifunk at somakoma dot de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+]]--
+
+m = Map("luci_statistics",
+ translate("OLSRd Plugin Configuration"),
+ translate("The OLSRd plugin reads information about meshed networks from the txtinfo plugin of OLSRd."))
+
+s = m:section(NamedSection, "collectd_olsrd", "luci_statistics" )
+
+enable = s:option(Flag, "enable", translate("Enable this plugin"))
+enable.default = 0
+
+host = s:option(Value, "Host", translate("Host"), translate("IP or hostname where to get the txtinfo output from"))
+host.placeholder = "127.0.0.1"
+host.datatype = "host"
+host.rmempty = true
+
+port = s:option(Value, "Port", translate("Port"))
+port.placeholder = "2006"
+port.datatype = "range(0,65535)"
+port.rmempty = true
+port.cast = "string"
+
+cl = s:option(ListValue, "CollectLinks", translate("CollectLinks"),
+ translate("Specifies what information to collect about links."))
+cl:value("No")
+cl:value("Summary")
+cl:value("Detail")
+cl.default = "Detail"
+
+cr = s:option(ListValue, "CollectRoutes", translate("CollectRoutes"),
+ translate("Specifies what information to collect about routes."))
+cr:value("No")
+cr:value("Summary")
+cr:value("Detail")
+cr.default = "Summary"
+
+ct = s:option(ListValue, "CollectTopology", translate("CollectTopology"),
+ translate("Specifies what information to collect about the global topology."))
+ct:value("No")
+ct:value("Summary")
+ct:value("Detail")
+ct.default = "Summary"
+
+return m