summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-smartdns/Makefile
diff options
context:
space:
mode:
authorNick Peng <pymumu@gmail.com>2020-03-20 23:17:26 +0800
committerNick Peng <pymumu@gmail.com>2020-03-20 23:17:26 +0800
commit7aad18cbac961f6ec75580c107e91d476fd4284a (patch)
tree7735e596b5ed2d0adc99d639445ce58d24f32ed7 /applications/luci-app-smartdns/Makefile
parent7b0ae114a87b297fbf383b9c2ee31f27101259aa (diff)
luci-app-smartdns: add new package
Signed-off-by: Nick Peng <pymumu@gmail.com>
Diffstat (limited to 'applications/luci-app-smartdns/Makefile')
-rw-r--r--applications/luci-app-smartdns/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/applications/luci-app-smartdns/Makefile b/applications/luci-app-smartdns/Makefile
new file mode 100644
index 000000000..878fbf739
--- /dev/null
+++ b/applications/luci-app-smartdns/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright 2018-2020 Nick Peng <pymumu@gmail.com>
+# Licensed to the public under the GPL V3 License.
+
+include $(TOPDIR)/rules.mk
+
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_MAINTAINER:=Nick Peng <pymumu@gmail.com>
+PKG_VERSION:=1.2020.30
+PKG_RELEASE:=1
+
+LUCI_TITLE:=LuCI for smartdns
+LUCI_DESCRIPTION:=Provides Luci for smartdns
+LUCI_DEPENDS:=+smartdns
+LUCI_PKGARCH:=all
+
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+endef
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature