summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-qos/luasrc/model/cbi/qos
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-qos/luasrc/model/cbi/qos
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-qos/luasrc/model/cbi/qos')
-rw-r--r--applications/luci-app-qos/luasrc/model/cbi/qos/qos.lua101
1 files changed, 101 insertions, 0 deletions
diff --git a/applications/luci-app-qos/luasrc/model/cbi/qos/qos.lua b/applications/luci-app-qos/luasrc/model/cbi/qos/qos.lua
new file mode 100644
index 000000000..6965078ed
--- /dev/null
+++ b/applications/luci-app-qos/luasrc/model/cbi/qos/qos.lua
@@ -0,0 +1,101 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+local wa = require "luci.tools.webadmin"
+local fs = require "nixio.fs"
+
+m = Map("qos", translate("Quality of Service"),
+ translate("With <abbr title=\"Quality of Service\">QoS</abbr> you " ..
+ "can prioritize network traffic selected by addresses, " ..
+ "ports or services."))
+
+s = m:section(TypedSection, "interface", translate("Interfaces"))
+s.addremove = true
+s.anonymous = false
+
+e = s:option(Flag, "enabled", translate("Enable"))
+e.rmempty = false
+
+c = s:option(ListValue, "classgroup", translate("Classification group"))
+c:value("Default", translate("default"))
+c.default = "Default"
+
+s:option(Flag, "overhead", translate("Calculate overhead"))
+
+s:option(Flag, "halfduplex", translate("Half-duplex"))
+
+dl = s:option(Value, "download", translate("Download speed (kbit/s)"))
+dl.datatype = "and(uinteger,min(1))"
+
+ul = s:option(Value, "upload", translate("Upload speed (kbit/s)"))
+ul.datatype = "and(uinteger,min(1))"
+
+s = m:section(TypedSection, "classify", translate("Classification Rules"))
+s.template = "cbi/tblsection"
+s.anonymous = true
+s.addremove = true
+s.sortable = true
+
+t = s:option(ListValue, "target", translate("Target"))
+t:value("Priority", translate("priority"))
+t:value("Express", translate("express"))
+t:value("Normal", translate("normal"))
+t:value("Bulk", translate("low"))
+t.default = "Normal"
+
+srch = s:option(Value, "srchost", translate("Source host"))
+srch.rmempty = true
+srch:value("", translate("all"))
+wa.cbi_add_knownips(srch)
+
+dsth = s:option(Value, "dsthost", translate("Destination host"))
+dsth.rmempty = true
+dsth:value("", translate("all"))
+wa.cbi_add_knownips(dsth)
+
+l7 = s:option(ListValue, "layer7", translate("Service"))
+l7.rmempty = true
+l7:value("", translate("all"))
+
+local pats = io.popen("find /etc/l7-protocols/ -type f -name '*.pat'")
+if pats then
+ local l
+ while true do
+ l = pats:read("*l")
+ if not l then break end
+
+ l = l:match("([^/]+)%.pat$")
+ if l then
+ l7:value(l)
+ end
+ end
+ pats:close()
+end
+
+p = s:option(Value, "proto", translate("Protocol"))
+p:value("", translate("all"))
+p:value("tcp", "TCP")
+p:value("udp", "UDP")
+p:value("icmp", "ICMP")
+p.rmempty = true
+
+ports = s:option(Value, "ports", translate("Ports"))
+ports.rmempty = true
+ports:value("", translate("all"))
+
+bytes = s:option(Value, "connbytes", translate("Number of bytes"))
+
+comment = s:option(Value, "comment", translate("Comment"))
+
+return m