summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-pbr
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2023-02-23 21:38:07 +0000
committerStan Grishin <stangri@melmac.ca>2023-02-23 21:48:13 +0000
commit0d4b675e7062ddc0d1d2b9be2d0962186239c51b (patch)
tree898f0fcdda762735305dcef513b99299cb8e9d97 /applications/luci-app-pbr
parenta505bb106701502f990fe397b3474ccccb8e4b4b (diff)
luci-app-pbr: bugfixes
* do not remove non-empty custom user files fields * add provides for vpnbypass and vpn-policy-routing luci apps addresses https://github.com/openwrt/luci/pull/6127#pullrequestreview-1311512052 Signed-off-by: Stan Grishin <stangri@melmac.ca>
Diffstat (limited to 'applications/luci-app-pbr')
-rw-r--r--applications/luci-app-pbr/Makefile4
-rw-r--r--applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js2
-rw-r--r--applications/luci-app-pbr/po/templates/pbr.pot2
3 files changed, 6 insertions, 2 deletions
diff --git a/applications/luci-app-pbr/Makefile b/applications/luci-app-pbr/Makefile
index 1d7eeeddab..e5f88c44dc 100644
--- a/applications/luci-app-pbr/Makefile
+++ b/applications/luci-app-pbr/Makefile
@@ -5,13 +5,15 @@ include $(TOPDIR)/rules.mk
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
-PKG_VERSION:=1.0.1-10
+PKG_VERSION:=1.1.0-1
LUCI_TITLE:=Policy Based Routing Service Web UI
LUCI_DESCRIPTION:=Provides Web UI for Policy Based Routing Service.
LUCI_DEPENDS:=+luci-base +jsonfilter +pbr
LUCI_PKGARCH:=all
+PKG_PROVIDES:=luci-app-vpnbypass luci-app-vpn-policy-routing
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js b/applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js
index e2d9d7b9b2..5ddf263a1e 100644
--- a/applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js
+++ b/applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js
@@ -267,10 +267,12 @@ return view.extend({
o = s.option(form.Flag, "enabled", _("Enabled"));
o.optional = false;
o.editable = true;
+ o.rmempty = false;
o = s.option(form.Value, "path", _("Path"));
o.optional = false;
o.editable = true;
+ o.rmempty = false;
return Promise.all([status.render(), m.render()]);
})
diff --git a/applications/luci-app-pbr/po/templates/pbr.pot b/applications/luci-app-pbr/po/templates/pbr.pot
index f8959174e8..f8827ce543 100644
--- a/applications/luci-app-pbr/po/templates/pbr.pot
+++ b/applications/luci-app-pbr/po/templates/pbr.pot
@@ -240,7 +240,7 @@ msgstr ""
msgid "Output verbosity"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js:271
+#: applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js:272
msgid "Path"
msgstr ""