summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-olsr/luasrc/view/status-olsr/mid.htm
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-olsr/luasrc/view/status-olsr/mid.htm
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-olsr/luasrc/view/status-olsr/mid.htm')
-rw-r--r--applications/luci-app-olsr/luasrc/view/status-olsr/mid.htm58
1 files changed, 58 insertions, 0 deletions
diff --git a/applications/luci-app-olsr/luasrc/view/status-olsr/mid.htm b/applications/luci-app-olsr/luasrc/view/status-olsr/mid.htm
new file mode 100644
index 0000000000..ec5caaa953
--- /dev/null
+++ b/applications/luci-app-olsr/luasrc/view/status-olsr/mid.htm
@@ -0,0 +1,58 @@
+<%#
+LuCI - Lua Configuration Interface
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+Copyright 2011 Manuel Munz <freifunk at somakoma dot de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+-%>
+<%
+local i = 1
+%>
+
+<%+header%>
+<h2><a id="content" name="content"><%:Active MID announcements%></a></h2>
+
+<div id="togglebuttons"></div>
+<fieldset class="cbi-section">
+ <legend><%:Overview of known multiple interface announcements%></legend>
+ <table class="cbi-section-table">
+ <tr class="cbi-section-table-titles">
+ <th class="cbi-section-table-cell"><%:OLSR node%></th>
+ <th class="cbi-section-table-cell" ><%:Secondary OLSR interfaces%></th>
+ </tr>
+
+ <% for k, mid in ipairs(mids) do
+ local aliases = ''
+ for k,v in ipairs(mid.aliases) do
+ if aliases == '' then
+ sep = ''
+ else
+ sep = ', '
+ end
+ aliases = v.ipAddress .. sep .. aliases
+ end
+ local host = mid.ipAddress
+ if mid.proto == '6' then
+ host = '[' .. mid.ipAddress .. ']'
+ end
+ %>
+
+ <tr class="cbi-section-table-row cbi-rowstyle-<%=i%> proto-<%=mid.proto%>">
+ <td class="cbi-section-table-cell"><a href="http://<%=host%>/cgi-bin-status.html"><%=mid.ipAddress%></a></td>
+ <td class="cbi-section-table-cell"><%=aliases%></td>
+ </tr>
+
+ <% i = ((i % 2) + 1)
+ end %>
+ </table>
+</fieldset>
+<%+status-olsr/common_js%>
+<%+footer%>