summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-ltqtapi/luasrc/view/telephony_status.htm
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-ltqtapi/luasrc/view/telephony_status.htm
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-ltqtapi/luasrc/view/telephony_status.htm')
-rw-r--r--applications/luci-app-ltqtapi/luasrc/view/telephony_status.htm32
1 files changed, 32 insertions, 0 deletions
diff --git a/applications/luci-app-ltqtapi/luasrc/view/telephony_status.htm b/applications/luci-app-ltqtapi/luasrc/view/telephony_status.htm
new file mode 100644
index 0000000000..234f909342
--- /dev/null
+++ b/applications/luci-app-ltqtapi/luasrc/view/telephony_status.htm
@@ -0,0 +1,32 @@
+<script type="text/javascript">//<![CDATA[
+XHR.poll(5, '<%=luci.dispatcher.build_url("admin", "telephony", "status")%>', null,
+ function(x, st)
+ {
+ var tb = document.getElementById('telephony_status_table');
+ if (st && tb)
+ {
+ tb.deleteRow(1);
+ var tr = tb.insertRow(-1);
+ tr.className = 'cbi-section-table-row cbi-rowstyle-1';
+
+ tr.insertCell(-1).innerHTML = st.status;
+ tr.insertCell(-1).innerHTML = st.line1;
+ tr.insertCell(-1).innerHTML = st.line2;
+ }
+ }
+);
+//]]></script>
+
+<fieldset class="cbi-section">
+ <legend><%:Current Telephony State%></legend>
+ <table class="cbi-section-table" id="telephony_status_table">
+ <tr class="cbi-section-table-titles">
+ <th class="cbi-section-table-cell"><%:Uplink%></th>
+ <th class="cbi-section-table-cell"><%:Port1%></th>
+ <th class="cbi-section-table-cell"><%:Port2%></th>
+ </tr>
+ <tr class="cbi-section-table-row">
+ <td colspan="5"><em><br /><%:Collecting data...%></em></td>
+ </tr>
+ </table>
+</fieldset>