summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-ltqtapi/luasrc/model
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-ltqtapi/luasrc/model
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-ltqtapi/luasrc/model')
-rw-r--r--applications/luci-app-ltqtapi/luasrc/model/cbi/luci_ltqtapi/account.lua26
-rw-r--r--applications/luci-app-ltqtapi/luasrc/model/cbi/luci_ltqtapi/contact.lua30
2 files changed, 56 insertions, 0 deletions
diff --git a/applications/luci-app-ltqtapi/luasrc/model/cbi/luci_ltqtapi/account.lua b/applications/luci-app-ltqtapi/luasrc/model/cbi/luci_ltqtapi/account.lua
new file mode 100644
index 000000000..40e00f346
--- /dev/null
+++ b/applications/luci-app-ltqtapi/luasrc/model/cbi/luci_ltqtapi/account.lua
@@ -0,0 +1,26 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2010 John Crispin <blogic@openwrt.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+m = Map("telephony", translate("VoIP"))
+m.on_after_commit = function() luci.sys.call("/etc/init.d/telephony restart") end
+
+s = m:section(TypedSection, "account", translate("Account"), translate("Here You can specify the SIP account that you want to use."))
+s.anonymous = true
+s.addremove = true
+
+s:option(Value, "realm", translate("Realm"))
+s:option(Value, "username", translate("Username"))
+s:option(Value, "password", translate("Password"))
+s:option(Flag, "disabled", translate("Disabled"))
+
+return m
diff --git a/applications/luci-app-ltqtapi/luasrc/model/cbi/luci_ltqtapi/contact.lua b/applications/luci-app-ltqtapi/luasrc/model/cbi/luci_ltqtapi/contact.lua
new file mode 100644
index 000000000..08311b515
--- /dev/null
+++ b/applications/luci-app-ltqtapi/luasrc/model/cbi/luci_ltqtapi/contact.lua
@@ -0,0 +1,30 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2010 John Crispin <blogic@openwrt.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+m = Map("telephony", translate("VoIP"))
+m.on_after_commit = function() luci.sys.call("/etc/init.d/telephony reload") end
+
+s = m:section(TypedSection, "contact", translate("Contact"), translate("Here You can specify the SIP contacts that you want to use."))
+s.anonymous = true
+s.addremove = true
+s.template = "cbi/tsection"
+
+s:option(Value, "desc", translate("Name"))
+s:option(Value, "code", translate("Shortdial"))
+s:option(Value, "dial", translate("Dial"))
+
+t = s:option(ListValue, "type", translate("Type"))
+t:value("sip", "SIP")
+t:value("realm", "Landline")
+
+return m