summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-libreswan/Makefile
diff options
context:
space:
mode:
authorJaymin Patel <jem.patel@gmail.com>2023-10-22 12:09:57 +0530
committerJo-Philipp Wich <jo@mein.io>2023-11-10 13:16:34 +0100
commit9f652445355258497fd7f8c7f06dd75f58cd64ce (patch)
tree17a23de32f15cc4f11f12fdac3a8e5375c889942 /applications/luci-app-libreswan/Makefile
parent5d3558f3f7eb96ea879e5d1c13a7baa1de5e7d25 (diff)
luci-app-libreswan: Add LuCI for Libreswan
LuCI Support for IPSec VPN (Libreswan) Signed-off-by: Jaymin Patel <jem.patel@gmail.com> [fix '15h' label typo] Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'applications/luci-app-libreswan/Makefile')
-rw-r--r--applications/luci-app-libreswan/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/applications/luci-app-libreswan/Makefile b/applications/luci-app-libreswan/Makefile
new file mode 100644
index 0000000000..4631c33eef
--- /dev/null
+++ b/applications/luci-app-libreswan/Makefile
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2022 Jaymin Patel <jem.patel@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_MAINTAINER:=Jaymin Patel <jem.patel@gmail.com>
+
+LUCI_TITLE=Luci Application for IPSec VPN (Libreswan)
+LUCI_DEPENDS:=+luci-base +libreswan
+LUCI_PKGARCH:=all
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
+