summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/search/main.htm
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/search/main.htm
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/search/main.htm')
-rw-r--r--applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/search/main.htm54
1 files changed, 54 insertions, 0 deletions
diff --git a/applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/search/main.htm b/applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/search/main.htm
new file mode 100644
index 0000000000..e319f15fbc
--- /dev/null
+++ b/applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/search/main.htm
@@ -0,0 +1,54 @@
+<%
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2012 Manuel Munz <freifunk at somakoma dot de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+local utl = require "luci.util"
+local title = luci.i18n.translate(data.title or "Search")
+local name = data['.name']
+local width = data.width or "100%"
+
+if type(width) == "number" then
+ width = width .. "px"
+end
+
+local engines = {}
+if type(data.engine) == "table" then
+ engines = data.engine
+else
+ for k, v in ipairs(string.split(data.engine, " ")) do
+ table.insert(engines, v)
+ end
+end
+%>
+
+<div id="<%=name%>" style="width:<%=width%>;float:left">
+ <h2><%=title%></h2>
+ <div id="form_<%=name%>">
+ <form name="searchform" id="search_<%=name%>" action="<%=luci.dispatcher.build_url('freifunk', 'search_redirect')%>">
+ <input type="text" name="searchterms" style="margin-bottom:15px; width: 90%"><br />
+ <%
+ local checked = " checked"
+ for k, v in ipairs(engines) do
+ local e = utl.split(v, "|")
+ local name = e[1]
+ local url = e[2]
+ if name and url then
+ %>
+ <input name="engine" type="radio" value="<%=url%>"<%=checked%>> <%=name%><br />
+ <% end
+ checked = ""
+ end
+%>
+ <input type="submit" name="SearchSubmit" value="Search" style="margin-top: 15px">
+ </form>
+ </div>
+</div>