summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/html/main.htm
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/html/main.htm
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/html/main.htm')
-rw-r--r--applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/html/main.htm42
1 files changed, 42 insertions, 0 deletions
diff --git a/applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/html/main.htm b/applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/html/main.htm
new file mode 100644
index 0000000000..87ad5b6292
--- /dev/null
+++ b/applications/luci-app-freifunk-widgets/luasrc/view/freifunk/widgets/html/main.htm
@@ -0,0 +1,42 @@
+<%
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2012 Manuel Munz <freifunk at somakoma dot de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+--local utl = require "luci.util"
+local fs = require "luci.fs"
+local title = data.title
+local name = data['.name']
+local file = "/usr/share/customtext/" .. name .. ".html"
+local text = fs.readfile(file)
+local width = data.width or "100%"
+local pr = data.paddingright or "0"
+if type(width) == "number" then
+ width = width .. "px"
+end
+
+%>
+
+<div id="<%=name%>" style="width:<%=width%>;float:left">
+ <div style="padding-right: <%=pr%>">
+ <% if title then %>
+ <h2><%=title%></h2>
+ <% end %>
+ <% if text then %>
+ <%=text%>
+ <%else%>
+ <%:Could not load the custom text from%> "<%=file%>!"
+ <%end%>
+
+ <%=data.text%>
+ </div>
+</div>