summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-ddns/root/etc/uci-defaults
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-ddns/root/etc/uci-defaults
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-ddns/root/etc/uci-defaults')
-rwxr-xr-xapplications/luci-app-ddns/root/etc/uci-defaults/luci-ddns24
1 files changed, 24 insertions, 0 deletions
diff --git a/applications/luci-app-ddns/root/etc/uci-defaults/luci-ddns b/applications/luci-app-ddns/root/etc/uci-defaults/luci-ddns
new file mode 100755
index 0000000000..5d3f56f984
--- /dev/null
+++ b/applications/luci-app-ddns/root/etc/uci-defaults/luci-ddns
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+# luci updates are not in sync with ddns-script updates !!!
+# needed because luci update might delete helper script
+# copy dynamic_dns_helper.tmp.sh from ddns-scripts
+cp -f /usr/lib/ddns/dynamic_dns_lucihelper.tmp.sh /usr/lib/ddns/dynamic_dns_lucihelper.sh
+
+# no longer needed for "Save and Apply" to restart ddns
+uci -q batch <<-EOF >/dev/null
+ delete ucitrack.@ddns[-1]
+ commit ucitrack
+EOF
+
+# make helper script executable
+chmod 755 /usr/lib/ddns/dynamic_dns_lucihelper.sh
+
+# update application section for luci-app-ddns
+uci -q get ddns.global > /dev/null || uci -q set ddns.global='ddns'
+uci -q get ddns.global.date_format > /dev/null || uci -q set ddns.global.date_format='%F %R'
+uci -q get ddns.global.log_lines > /dev/null || uci -q set ddns.global.log_lines='250'
+uci -q commit ddns
+
+rm -f /tmp/luci-indexcache
+exit 0