summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-bmx7/root/usr/lib/lua
diff options
context:
space:
mode:
authorMustafa Can Elmacı <mustafacan@elmaci.net>2024-11-17 15:52:45 +0300
committerPaul Donald <newtwen+github@gmail.com>2024-11-22 22:39:46 +0100
commitae8bbb814f16c2dc2a82e88d408bee1812ceda9c (patch)
treeb48de027e4f3d6a366ef60025b980bc83ee5ae90 /applications/luci-app-bmx7/root/usr/lib/lua
parentaa955d6465b4d0f00cc713904e2de7bfb0cbd062 (diff)
treewide: HTML Cleanup
* HTML Cleanup: Meta tags. * Converted charset to shorthand. * Removed meta tags with `Content-Script-Type` attribute. (Invalid in HTML5 spec.) * HTML Cleanup: CSS tags. * Removed `type` attribute with CSS files from link tags. (HTML5 spec recommends omitting it.) * Removed `type` attribute from style tags. (Deprecated in HTML5 spec.) https://html.spec.whatwg.org/#attr-link-type https://developer.mozilla.org/en-US/docs/Web/HTML/Element/style * HTML Cleanup: Convert from XHTML to HTML5 * Removed XML declaration. * Removed XML namespace. * Changed doctype to HTML5. * HTML Cleanup: CDATA tags. * CDATA sections should not be used within HTML they are considered as comments and not displayed. https://developer.mozilla.org/en-US/docs/Web/API/CDATASection * HTML Cleanup: Script tags. * Removed `language` attribute from script tags. (No longer valid in HTML5) * Removed `type` attribute with JavaScript MIME type from script tags. (HTML5 spec recommends omitting it.) https://html.spec.whatwg.org/multipage/scripting.html#attr-script-type https://mimesniff.spec.whatwg.org/#javascript-mime-type Signed-off-by: Mustafa Can Elmacı <mustafacan@elmaci.net>
Diffstat (limited to 'applications/luci-app-bmx7/root/usr/lib/lua')
-rw-r--r--applications/luci-app-bmx7/root/usr/lib/lua/luci/view/admin_status/index/bmx7_nodes.htm6
-rw-r--r--applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/nodes_j.htm8
-rw-r--r--applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/status_j.htm8
-rw-r--r--applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/topology.htm4
-rw-r--r--applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/tunnels_j.htm8
5 files changed, 17 insertions, 17 deletions
diff --git a/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/admin_status/index/bmx7_nodes.htm b/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/admin_status/index/bmx7_nodes.htm
index 32a3a965ce..c8ddb2d8e8 100644
--- a/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/admin_status/index/bmx7_nodes.htm
+++ b/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/admin_status/index/bmx7_nodes.htm
@@ -18,8 +18,8 @@
</div>
</div>
-<script type="text/javascript" src="<%=resource%>/bmx7/js/polling.js"></script>
-<script type="text/javascript">//<![CDATA[
+<script src="<%=resource%>/bmx7/js/polling.js"></script>
+<script>
new TablePooler(10,"/cgi-bin/bmx7-info", {'originators':''}, "nodes_div", function(st){
var originators = st.originators;
var res = Array();
@@ -37,4 +37,4 @@
});
return res;
});
-//]]></script>
+</script>
diff --git a/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/nodes_j.htm b/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/nodes_j.htm
index 16522b962c..bbbeb52c0e 100644
--- a/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/nodes_j.htm
+++ b/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/nodes_j.htm
@@ -22,8 +22,8 @@
-%>
<%+header%>
-<script type="text/javascript" src="<%=resource%>/cbi.js"></script>
-<script type="text/javascript" src="<%=resource%>/bmx7/js/polling.js"></script>
+<script src="<%=resource%>/cbi.js"></script>
+<script src="<%=resource%>/bmx7/js/polling.js"></script>
<style>
@@ -88,7 +88,7 @@
</div>
-<script type="text/javascript">//<![CDATA[
+<script>
var displayExtraInfo = function ( id ) {
document.getElementById('extra-info').innerHTML = document.getElementById(id).innerHTML;
}
@@ -150,6 +150,6 @@
});
return res;
});
-//]]></script>
+</script>
<%+footer%>
diff --git a/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/status_j.htm b/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/status_j.htm
index a3249a2b14..bfabf1ea50 100644
--- a/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/status_j.htm
+++ b/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/status_j.htm
@@ -1,6 +1,6 @@
<%+header%>
-<script type="text/javascript" src="<%=resource%>/cbi.js"></script>
-<script type="text/javascript" src="<%=resource%>/bmx7/js/polling.js"></script>
+<script src="<%=resource%>/cbi.js"></script>
+<script src="<%=resource%>/bmx7/js/polling.js"></script>
<div class="cbi-map">
<center>
@@ -87,7 +87,7 @@
</div>
-<script type="text/javascript">//<![CDATA[
+<script>
new TablePooler(10,"/cgi-bin/bmx7-info", {'info':''}, "config_div", function(st){
var res = Array();
var sta = st.info[0].status;
@@ -125,6 +125,6 @@
return res;
});
-//]]></script>
+</script>
<%+footer%>
diff --git a/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/topology.htm b/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/topology.htm
index 4a688bde61..1f09cc4ac1 100644
--- a/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/topology.htm
+++ b/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/topology.htm
@@ -1,9 +1,9 @@
<%+header%>
<script src="https://cdnjs.cloudflare.com/ajax/libs/d3/3.5.12/d3.min.js" integrity="sha512-uy3foVtL4u0+5430l7zZt4PHjVtICfrbu3mtzdanR425sKD7kS5264djeZAzNIV0l4vc1QkFpW2+G5i5KoJIFQ==" crossorigin="anonymous" referrerpolicy="no-referrer"></script>
-<script type="text/javascript" src="<%=resource%>/bmx7/js/netjsongraph.js"></script>
+<script src="<%=resource%>/bmx7/js/netjsongraph.js"></script>
<link href="<%=resource%>/bmx7/css/netjsongraph.css" rel="stylesheet">
- <style type="text/css">
+<style>
body {
font-family: Arial, sans-serif;
font-size: 13px;
diff --git a/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/tunnels_j.htm b/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/tunnels_j.htm
index 0b9662df8c..9b99cdd325 100644
--- a/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/tunnels_j.htm
+++ b/applications/luci-app-bmx7/root/usr/lib/lua/luci/view/bmx7/tunnels_j.htm
@@ -22,8 +22,8 @@
<%+header%>
-<script type="text/javascript" src="<%=resource%>/cbi.js"></script>
-<script type="text/javascript" src="<%=resource%>/bmx7/js/polling.js"></script>
+<script src="<%=resource%>/cbi.js"></script>
+<script src="<%=resource%>/bmx7/js/polling.js"></script>
<div class="cbi-map">
<h2>Gateway announcements</h2>
@@ -50,7 +50,7 @@
</div>
-<script type="text/javascript">//<![CDATA[
+<script>
new TablePooler(5,"/cgi-bin/bmx7-info", {'tunnels':''}, "tunnels_div", function(st){
var tunicon = "<%=resource%>/icons/tunnel.png";
var tunicon_dis = "<%=resource%>/icons/tunnel_disabled.png";
@@ -71,6 +71,6 @@
}
return res;
});
-//]]></script>
+</script>
<%+footer%>