summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-advanced-reboot/Makefile
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.net>2017-07-12 22:51:41 -0700
committerStan Grishin <stangri@melmac.net>2017-07-12 23:21:36 -0700
commitf6505fc01c8aee4d2f9f7bc7537c3a93cfd5dab1 (patch)
tree11c110dc7651267458dcd9d83adeada28b8fff6b /applications/luci-app-advanced-reboot/Makefile
parent00ae50134bba7df05e1c6743d250f0137261fdb7 (diff)
luci-app-advanced-reboot: initial commit
Signed-off-by: Stan Grishin <stangri@melmac.net>
Diffstat (limited to 'applications/luci-app-advanced-reboot/Makefile')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
new file mode 100644
index 000000000..3a886eb8d
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -0,0 +1,20 @@
+# Copyright (c) 2017 Stan Grishin (stangri@melmac.net)
+# This is free software, licensed under the GNU General Public License v3.
+
+include $(TOPDIR)/rules.mk
+
+PKG_LICENSE:=GPL-3.0+
+PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
+
+LUCI_TITLE:=Advanced Linksys Reboot Web UI
+LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot supported Linksys routers to\
+ an altnerative partition. Also provides Web UI to shut down (power off) your device. Supported dual-partition\
+ routers are listed at https://github.com/stangri/openwrt-luci/blob/luci-app-advanced-reboot/applications/luci-app-advanced-reboot/README.md
+
+LUCI_DEPENDS:=+luci
+LUCI_PKGARCH:=all
+PKG_RELEASE:=23
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature