summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-07-29 21:16:12 +0000
committerSteven Barth <steven@midlink.org>2008-07-29 21:16:12 +0000
commit8c3ee6f9b7e5ab0b4edbf4838c7c1a9ee6d7df5d (patch)
treecfc137969531140b44fe4c15ac11587fdb7f7ebd /Makefile
parent5b43543226fa29dc7d899e9fc82f0179aefcb56b (diff)
Added "apidocs" target to Makefile
contrib/luadoc: Added luadoc executable libs: Fixed typos in inline documentation
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 12c1d89e0..a9e5e1eb2 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,7 @@ luabuild:
for i in $(MODULES); do make -C$$i lua$(LUA_TARGET); done
clean:
+ rm -rf docs
for i in $(MODULES); do make -C$$i clean; done
@@ -58,6 +59,9 @@ runshell: hostenv
hostclean: clean
rm -rf host
+apidocs: hostenv
+ build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh host/luci/ docs"
+
run:
# make run is deprecated #
# Please use: #