summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-08-19 01:22:23 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-08-19 01:22:23 +0000
commit405d42a40c186134fcb605bd99fe9e6293164a3e (patch)
tree8e2c12c0978a1da09150e7df1f7367c509c4b036 /Makefile
parentf12f7c5b5ad36b07f5cb73200625fb49704791d7 (diff)
build: introduce $(SDK) to test whether we run a target build or the sdk
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 3bf8c68de1..3b46544a4c 100644
--- a/Makefile
+++ b/Makefile
@@ -12,22 +12,24 @@ all: build
build: gccbuild luabuild
gccbuild:
- make -C libs/lmo CC="cc" CFLAGS="" LDFLAGS="" host-install
+ make -C libs/lmo CC="cc" CFLAGS="" LDFLAGS="" SDK="$(shell test -f .running-sdk && echo 1)" host-install
for i in $(MODULES); do \
- make -C$$i compile || { \
+ make -C$$i SDK="$(shell test -f .running-sdk && echo 1)" compile || { \
echo "*** Compilation of $$i failed!"; \
exit 1; \
}; \
done
luabuild: i18nbuild
- for i in $(MODULES); do HOST=$(realpath host) make -C$$i luabuild; done
+ for i in $(MODULES); do HOST=$(realpath host) \
+ SDK="$(shell test -f .running-sdk && echo 1)" make -C$$i luabuild; done
i18nbuild:
mkdir -p host/lua-po
./build/i18n-po2lua.pl ./po host/lua-po
clean:
+ rm -f .running-sdk
rm -rf docs
make -C libs/lmo host-clean
for i in $(MODULES); do make -C$$i clean; done
@@ -48,7 +50,10 @@ hostcopy:
ln -s .$(LUCI_MODULEDIR) host/luci
rm -rf /tmp/luci-* || true
-hostenv: host ucidefaults
+hostenv: sdk host ucidefaults
+
+sdk:
+ touch .running-sdk
ucidefaults:
build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host)/bin/uci-defaults --exclude luci-freifunk-*"