summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-08 20:59:08 +0000
committerSteven Barth <steven@midlink.org>2008-05-08 20:59:08 +0000
commitff955885022ee77d783f089b12926954be1acda8 (patch)
tree2a8c4199dadf5c05517006937ac491b227f380b0
parentf547a274f7c1ab03ad7463c227146b4683e9be27 (diff)
* applications/luci-splash: Minor bugfixes
-rw-r--r--applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi4
-rw-r--r--contrib/package/ffluci/Makefile1
2 files changed, 3 insertions, 2 deletions
diff --git a/applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi b/applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi
index 3bff85ee5..341aaa4b5 100644
--- a/applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi
+++ b/applications/luci-splash/root/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi
@@ -8,7 +8,7 @@ require("ffluci.model.uci")
local srv
local net
-local ip = ffluci.http.remote_addr()
+local ip = ffluci.http.env.REMOTE_ADDR
for k, v in pairs(ffluci.model.uci.sections("network")) do
if v[".type"] == "interface" and v.ipaddr then
local p = ffluci.sys.net.mask4prefix(v.netmask)
@@ -28,7 +28,7 @@ for k, v in pairs(ffluci.model.uci.sections("luci_splash")) do
end
if not srv then
- ffluci.http.textheader()
+ ffluci.http.prepare_content("text/plain")
return print("Unable to detect network settings!")
end
diff --git a/contrib/package/ffluci/Makefile b/contrib/package/ffluci/Makefile
index 8b51e9703..f0f43db99 100644
--- a/contrib/package/ffluci/Makefile
+++ b/contrib/package/ffluci/Makefile
@@ -154,6 +154,7 @@ define Package/ffluci-app-splash/install
$(call Package/ffluci/install/template,$(1),applications/luci-splash)
$(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/usr/sbin/luci-splash $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/etc/init.d/luci_splash $(1)/etc/init.d
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-splash/dist/usr/lib/luci-splash/htdocs/cgi-bin/index.cgi $(1)/usr/lib/luci-splash/htdocs/cgi-bin
endef