summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2024-03-24 07:55:13 -0600
committerGitHub <noreply@github.com>2024-03-24 07:55:13 -0600
commite0542c28fbe7df2cdf7a88b4b0d7bf5f38ce5016 (patch)
tree5b6856c583372db6a34cfa8e15502e832549300b
parentae2b577e18e359f78d093db9b5871926523797cc (diff)
parent1efb3cd5f898e41148b298ae6ecdec4a7ae558f8 (diff)
Merge pull request #7013 from stangri/master-luci-app-https-dns-proxy
luci-app-https-dns-proxy: prepare migration to APK
-rw-r--r--applications/luci-app-https-dns-proxy/Makefile2
-rwxr-xr-xapplications/luci-app-https-dns-proxy/root/usr/libexec/rpcd/luci.https-dns-proxy2
2 files changed, 2 insertions, 2 deletions
diff --git a/applications/luci-app-https-dns-proxy/Makefile b/applications/luci-app-https-dns-proxy/Makefile
index 3e6209c137..4ef756b719 100644
--- a/applications/luci-app-https-dns-proxy/Makefile
+++ b/applications/luci-app-https-dns-proxy/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
-PKG_VERSION:=2023-11-19-1
+PKG_VERSION:=2023.11.19-r1
LUCI_TITLE:=DNS Over HTTPS Proxy Web UI
LUCI_DESCRIPTION:=Provides Web UI for DNS Over HTTPS Proxy
diff --git a/applications/luci-app-https-dns-proxy/root/usr/libexec/rpcd/luci.https-dns-proxy b/applications/luci-app-https-dns-proxy/root/usr/libexec/rpcd/luci.https-dns-proxy
index 593af173fc..3a05b33a3a 100755
--- a/applications/luci-app-https-dns-proxy/root/usr/libexec/rpcd/luci.https-dns-proxy
+++ b/applications/luci-app-https-dns-proxy/root/usr/libexec/rpcd/luci.https-dns-proxy
@@ -19,7 +19,7 @@ readonly providersDir="/usr/share/${packageName}/providers"
is_enabled() { "/etc/init.d/${1}" enabled; }
is_running() { [ "$(ubus call service list "{ 'name': '$1' }" | jsonfilter -q -e "@['$1'].instances[*].running" | uniq)" = 'true' ]; }
-get_version() { grep -m1 -A2 -w "^Package: $1$" /usr/lib/opkg/status | sed -n 's/Version: //p'; }
+get_version() { /usr/sbin/https-dns-proxy -V; }
check_http2() { curl --version | grep -q 'nghttp2'; }
check_http3() { curl --version | grep -q 'nghttp3'; }
ubus_get_ports() { ubus call service list "{ 'name': '$packageName' }" | jsonfilter -e "@['${packageName}'].instances[*].data.firewall.*.dest_port"; }