summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2024-11-21 22:17:04 +0100
committerRobert Marko <robimarko@gmail.com>2024-11-23 13:06:31 +0100
commit9e70c9aed8b0c87a4c5f03eb0cfbca9f6970192a (patch)
treec32a92f74b208570254c9e00ebee18ae644b9129
parent03f37cff4c1cd73993284779f92c4982d30aa2bd (diff)
collections: select package manager for SSL collections
Currently, the regular and nginx collections include package manager by default but SSL collections dont, so lets include package manager on SSL collections as well. Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--collections/luci-ssl-openssl/Makefile5
-rw-r--r--collections/luci-ssl/Makefile5
2 files changed, 8 insertions, 2 deletions
diff --git a/collections/luci-ssl-openssl/Makefile b/collections/luci-ssl-openssl/Makefile
index 127db14d8f..df019b2ebb 100644
--- a/collections/luci-ssl-openssl/Makefile
+++ b/collections/luci-ssl-openssl/Makefile
@@ -14,7 +14,10 @@ LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
OpenSSL cmd tools (openssl-util) are used by uhttpd for SSL key generation \
instead of the default px5g. (If px5g is installed, uhttpd will prefer that.)
-LUCI_DEPENDS:=+luci-light +libustream-openssl +openssl-util
+LUCI_DEPENDS:=+luci-light \
+ +libustream-openssl \
+ +openssl-util \
+ +luci-app-package-manager
PKG_LICENSE:=Apache-2.0
diff --git a/collections/luci-ssl/Makefile b/collections/luci-ssl/Makefile
index fabc573e7d..6c89b6abad 100644
--- a/collections/luci-ssl/Makefile
+++ b/collections/luci-ssl/Makefile
@@ -10,7 +10,10 @@ LUCI_TYPE:=col
LUCI_BASENAME:=ssl
LUCI_TITLE:=LuCI with HTTPS support (mbedtls as SSL backend)
-LUCI_DEPENDS:=+luci-light +libustream-mbedtls +px5g-mbedtls
+LUCI_DEPENDS:=+luci-light \
+ +libustream-mbedtls \
+ +px5g-mbedtls \
+ +luci-app-package-manager
PKG_LICENSE:=Apache-2.0