diff options
author | Mikael Magnusson <mikma@users.sourceforge.net> | 2018-12-20 20:59:37 +0000 |
---|---|---|
committer | Mikael Magnusson <mikma@users.sourceforge.net> | 2018-12-20 21:02:21 +0000 |
commit | 073b825d99f35b2e010923ab0a4141ea312bf7d3 (patch) | |
tree | 7eec7ca3a0563fed9186e40faf18e0d2f7fe919d /build.sh | |
parent | 6dfa16a9f7527bfbffe6064ca6006daac08e5a9d (diff) |
Add support for armvirt-64 AKA aarch64
Tested with qemu emulation only.
Diffstat (limited to 'build.sh')
-rwxr-xr-x | build.sh | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -57,10 +57,17 @@ case "$arch_lxd" in i686) arch=x86 subarch=generic + arch_ipk=i386_pentium4 ;; x86_64) arch=x86 subarch=64 + arch_ipk=x86_64 + ;; + aarch64) + arch=armvirt + subarch=64 + arch_ipk=aarch64_generic ;; *) usage @@ -97,7 +104,7 @@ detect_url() { } download_rootfs() { - detect_url "generic-rootfs" + detect_url "rootfs\.tar" local rootfs_url=$openwrt_url/$return # global $rootfs @@ -184,7 +191,7 @@ build_procd() { local version=$(grep PKG_SOURCE_VERSION:= dl/procd-${openwrt_branch}/Makefile | cut -d '=' -f 2 | cut -b '1-8') local release=$(grep PKG_RELEASE:= dl/procd-${openwrt_branch}/Makefile | cut -d '=' -f 2) local ipk_old=$sdk/bin/targets/${arch}/${subarch}/packages/procd_${date}-${version}-${release}_*.ipk - local ipk_new=$sdk/bin/packages/${arch_lxd}/base/procd_${date}-${version}-${release}_*.ipk + local ipk_new=$sdk/bin/packages/${arch_ipk}/base/procd_${date}-${version}-${release}_*.ipk if test $ver \< 18; then local ipk=$ipk_old |