summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9de32908..b0555999 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,6 +12,12 @@ AC_ARG_ENABLE([client],
[enable_client=yes]
)
+AC_ARG_ENABLE([static-lib],
+ [AS_HELP_STRING([--enable-static-lib], [enable building of BIRD daemon static library @<:@no@:>@])],
+ [],
+ [enable_static_lib=no]
+)
+
AC_ARG_ENABLE([debug],
[AS_HELP_STRING([--enable-debug], [enable internal debugging routines @<:@no@:>@])],
[],
@@ -456,6 +462,12 @@ fi
AC_SUBST([CLIENT])
AC_SUBST([CLIENT_LIBS])
+STATIC_LIB=
+if test "$enable_static_lib" = yes ; then
+ STATIC_LIB="$STATIC_LIB libbird.a"
+fi
+AC_SUBST([STATIC_LIB])
+
mkdir -p $objdir/sysdep
AC_CONFIG_HEADERS([$objdir/sysdep/autoconf.h:sysdep/autoconf.h.in])
AC_CONFIG_FILES([Makefile:Makefile.in])
@@ -473,5 +485,6 @@ AC_MSG_RESULT([ Routing protocols: $protocols])
AC_MSG_RESULT([ LibSSH support in RPKI: $enable_libssh])
AC_MSG_RESULT([ Kernel MPLS support: $enable_mpls_kernel])
AC_MSG_RESULT([ Client: $enable_client])
+AC_MSG_RESULT([ Static lib: $enable_static_lib])
rm -f $objdir/.*-stamp