summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMikael Magnusson <mikma@users.sourceforge.net>2019-04-11 01:29:12 +0200
committerMikael Magnusson <mikma@users.sourceforge.net>2021-01-12 23:34:17 +0100
commit6ae9a32cd656e4398c11e851e959a0dd85f3c072 (patch)
treeebef928017286268ab0bcf80ac668217c9e6d784 /configure.ac
parent50f4916fce668186c270550053978e13cb700f8a (diff)
Android: Disable include patterns if glob is unsupported
Because of missing glob() in NDK platforms before 28
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3ec309bf..4b6c31cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -361,10 +361,11 @@ AC_C_BIGENDIAN(
)
BIRD_CHECK_ANDROID_GLOB
-if test "$bird_cv_lib_glob" = no ; then
- AC_MSG_ERROR([glob.h not found.])
-elif test "$bird_cv_lib_glob" != yes ; then
- LIBS="$LIBS $bird_cv_lib_glob"
+if test "$bird_cv_lib_glob" != no ; then
+ AC_DEFINE([HAVE_GLOB], [1], [Define to 1 if you have glob()])
+ if test "$bird_cv_lib_glob" != yes ; then
+ LIBS="$LIBS $bird_cv_lib_glob"
+ fi
fi
BIRD_CHECK_ANDROID_LOG