summaryrefslogtreecommitdiffhomepage
path: root/tunnel/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'tunnel/build.gradle')
-rw-r--r--tunnel/build.gradle16
1 files changed, 16 insertions, 0 deletions
diff --git a/tunnel/build.gradle b/tunnel/build.gradle
index 8cffa1e6..bb7d5111 100644
--- a/tunnel/build.gradle
+++ b/tunnel/build.gradle
@@ -87,4 +87,20 @@ protobuf {
}
}
+afterEvaluate({ project ->
+ // All custom configurations created by the protobuf plugin,
+ // are only available at this point.
+ def protoc = configurations.getByName('protobufToolsLocator_protoc')
+
+ task copyProtoc(type: Copy) {
+ // Used by tunnel/tools/libwg-go/Makefile run in tools/CMakeLists.txt
+ from protoc
+ into "${gradle.gradleUserHomeDir}/caches/protoc-${protocVersion}"
+ rename 'protoc-.*', 'protoc'
+ fileMode 0775
+ }
+
+ preBuild.dependsOn copyProtoc
+})
+
apply from: "publish.gradle"