summaryrefslogtreecommitdiffhomepage
path: root/tunnel/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2023-04-04 14:20:02 +0200
committerJason A. Donenfeld <Jason@zx2c4.com>2023-04-04 15:14:28 +0200
commit9fae3273156fc4adfd631424c812ab83e563dd36 (patch)
tree5b57b27136986b98c279301309e70f3fa5d5a955 /tunnel/tools/CMakeLists.txt
parenta6f5eb0dd2674f9285209a9f46e6e0f9ee15962e (diff)
tools: pass -Wl,--build-id=none and -buildid= to toolchain
Unfortunately, we need to fix this up in both the Makefile and in CMake, because add_link_options doesn't immediately reflect on the CMake variables in scope. Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
Diffstat (limited to 'tunnel/tools/CMakeLists.txt')
-rw-r--r--tunnel/tools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tunnel/tools/CMakeLists.txt b/tunnel/tools/CMakeLists.txt
index 7cffc4ac..a63d8335 100644
--- a/tunnel/tools/CMakeLists.txt
+++ b/tunnel/tools/CMakeLists.txt
@@ -5,6 +5,7 @@
cmake_minimum_required(VERSION 3.4.1)
project("WireGuard")
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}")
+add_link_options(LINKER:--build-id=none)
add_executable(libwg-quick.so wireguard-tools/src/wg-quick/android.c ndk-compat/compat.c)
target_compile_options(libwg-quick.so PUBLIC -O3 -std=gnu11 -Wall -include ${CMAKE_CURRENT_SOURCE_DIR}/ndk-compat/compat.h -DWG_PACKAGE_NAME=\"${ANDROID_PACKAGE_NAME}\")