summaryrefslogtreecommitdiffhomepage
path: root/tunnel/build.gradle
diff options
context:
space:
mode:
authorMikael Magnusson <mikma@users.sourceforge.net>2022-05-20 17:40:44 +0200
committerMikael Magnusson <mikma@users.sourceforge.net>2022-06-10 22:26:28 +0200
commitf41374e0d4eac546a18a8d0926ec4cfa48a2cbb6 (patch)
treecdd12072e4afe5230ad2abd124742908120bf04e /tunnel/build.gradle
parent38526ef9b568d3a41d7d612aa2764a9cd564ce5d (diff)
tunnel: fix path to protoc and update protobuf
Diffstat (limited to 'tunnel/build.gradle')
-rw-r--r--tunnel/build.gradle16
1 files changed, 16 insertions, 0 deletions
diff --git a/tunnel/build.gradle b/tunnel/build.gradle
index 8cffa1e6..bb7d5111 100644
--- a/tunnel/build.gradle
+++ b/tunnel/build.gradle
@@ -87,4 +87,20 @@ protobuf {
}
}
+afterEvaluate({ project ->
+ // All custom configurations created by the protobuf plugin,
+ // are only available at this point.
+ def protoc = configurations.getByName('protobufToolsLocator_protoc')
+
+ task copyProtoc(type: Copy) {
+ // Used by tunnel/tools/libwg-go/Makefile run in tools/CMakeLists.txt
+ from protoc
+ into "${gradle.gradleUserHomeDir}/caches/protoc-${protocVersion}"
+ rename 'protoc-.*', 'protoc'
+ fileMode 0775
+ }
+
+ preBuild.dependsOn copyProtoc
+})
+
apply from: "publish.gradle"