summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6506b1a..6d76f3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -154,13 +154,14 @@ ENDIF()
IF(NL80211_SUPPORT)
FIND_LIBRARY(nl NAMES nl-tiny)
+ FIND_LIBRARY(ubox NAMES ubox)
FIND_PATH(nl_include_dir NAMES netlink/msg.h PATH_SUFFIXES libnl-tiny)
INCLUDE_DIRECTORIES(${nl_include_dir})
SET(LIBRARIES ${LIBRARIES} nl80211_lib)
ADD_LIBRARY(nl80211_lib MODULE lib/nl80211.c)
SET_TARGET_PROPERTIES(nl80211_lib PROPERTIES OUTPUT_NAME nl80211 PREFIX "")
TARGET_LINK_OPTIONS(nl80211_lib PRIVATE ${UCODE_MODULE_LINK_OPTIONS})
- TARGET_LINK_LIBRARIES(nl80211_lib ${nl})
+ TARGET_LINK_LIBRARIES(nl80211_lib ${nl} ${ubox})
ENDIF()
IF(RESOLV_SUPPORT)