summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index adc04ec..4564818 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,7 @@ find_library(libuci NAMES uci)
find_library(libubox NAMES ubox)
find_library(libubus NAMES ubus)
find_library(libblobmsg_json NAMES blobmsg_json)
+find_package(ZLIB)
if(LINUX)
find_library(libnl_tiny NAMES nl-tiny)
@@ -49,6 +50,10 @@ if(libubox)
set(DEFAULT_ULOOP_SUPPORT ON)
endif()
+if(ZLIB_FOUND)
+ set(DEFAULT_ZLIB_SUPPORT ON)
+endif()
+
option(DEBUG_SUPPORT "Debug plugin support" ON)
option(FS_SUPPORT "Filesystem plugin support" ON)
option(MATH_SUPPORT "Math plugin support" ON)
@@ -61,6 +66,7 @@ option(STRUCT_SUPPORT "Struct plugin support" ON)
option(ULOOP_SUPPORT "Uloop plugin support" ${DEFAULT_ULOOP_SUPPORT})
option(LOG_SUPPORT "Log plugin support" ON)
option(SOCKET_SUPPORT "Socket plugin support" ON)
+option(ZLIB_SUPPORT "Zlib plugin support" ${DEFAULT_ZLIB_SUPPORT})
set(LIB_SEARCH_PATH "${CMAKE_INSTALL_PREFIX}/lib/ucode/*.so:${CMAKE_INSTALL_PREFIX}/share/ucode/*.uc:./*.so:./*.uc" CACHE STRING "Default library search path")
string(REPLACE ":" "\", \"" LIB_SEARCH_DEFINE "${LIB_SEARCH_PATH}")
@@ -276,6 +282,14 @@ if(SOCKET_SUPPORT)
target_link_options(socket_lib PRIVATE ${UCODE_MODULE_LINK_OPTIONS})
endif()
+if(ZLIB_SUPPORT)
+ set(LIBRARIES ${LIBRARIES} zlib_lib)
+ add_library(zlib_lib MODULE lib/zlib.c)
+ set_target_properties(zlib_lib PROPERTIES OUTPUT_NAME zlib PREFIX "")
+ target_link_options(zlib_lib PRIVATE ${UCODE_MODULE_LINK_OPTIONS})
+ target_link_libraries(zlib_lib ZLIB::ZLIB)
+endif()
+
if(UNIT_TESTING)
enable_testing()
add_definitions(-DUNIT_TESTING)