summaryrefslogtreecommitdiffhomepage
path: root/tests/custom/CMakeLists.txt
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2024-07-29 12:32:56 +0200
committerJo-Philipp Wich <jo@mein.io>2024-07-29 14:09:47 +0200
commitfbabec42349880407c4308211129c07ff51c484a (patch)
treef2a95a1083f4f02b1791ad6577dc5a9307b8ba7a /tests/custom/CMakeLists.txt
parente391ef5631cdc2a9f7f69504cd1e57d7ca510969 (diff)
tests: replace test runner shell script with ucode implementation
The ucode interpreter and libraries are mature enough to execute their own testcases now, so replace the existing shell script with an equivalent ucode implementation. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'tests/custom/CMakeLists.txt')
-rw-r--r--tests/custom/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/custom/CMakeLists.txt b/tests/custom/CMakeLists.txt
index c8007a0..c94278e 100644
--- a/tests/custom/CMakeLists.txt
+++ b/tests/custom/CMakeLists.txt
@@ -1,6 +1,6 @@
ADD_TEST(
NAME custom
- COMMAND run_tests.sh
+ COMMAND $<TARGET_FILE:ucode> -L $<TARGET_FILE_DIR:fs_lib>/*.so -S run_tests.uc
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
)
SET_PROPERTY(TEST custom APPEND PROPERTY ENVIRONMENT
@@ -11,7 +11,7 @@ SET_PROPERTY(TEST custom APPEND PROPERTY ENVIRONMENT
IF(CMAKE_C_COMPILER_ID STREQUAL "Clang")
ADD_TEST(
NAME custom-san
- COMMAND run_tests.sh
+ COMMAND $<TARGET_FILE:ucode> -L $<TARGET_FILE_DIR:fs_lib>/*.so -S run_tests.uc
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
)